Filebeat and Minimal Server Install

Hi folks, new user here.

I just spent the last two days bashing my head against the wall trying to determine why a minimal server setup (Centos 8) would not send beat info to a remote logstash system.

So after exhausting all alternatives, I did a fresh install of Centos 8 Server with GUI on a separate instance. And well, guess what? Beat worked like a charm!

So I am wondering what Beat needs to work properly using a minimal setup? Have any of you run into this?


1 Like

I just signed up to post this exact question.

I've set up the basic ELK stack 3-4 times already. But everytime I try to connect a Filebeat node and send logs, it never reaches my Elasticsearch/Logstash.

Because there are so many components, I am also looking for a "bare minimum working setup" of ELK + Filebeat.

(I also have been trying to get this working for the last 2 days and nights. Followed the instructions, and various youtube videos. Even digitalocean's guides. Tried a plain Ubuntu VM, then Bitnami's pre-build OVA VMs, and now trying Docker.)

Thanks for responding. Al least I know I'm not losing my mind LOL!

From my side it makes no sense. TCPDump shows communication to and from the two systems, yet nothing shows up.

Sure enough, I converted my minimal install setup to Server with GUI and Beats started working immediately. So it is clear something is being added that isn't being included with a Beats install.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.