Filebeat cannot connect to ELK

Hey, i'm trying to input the apache2 visualize dashboard but when i run this command said connection refused

everytime i try try to connect to my ELK in my VM1 with my webserver with apache2 and filebeat, the connection is always refused. I have tried to disabled ufw but it still not works.

this is what happened when i run filebeat test output

if you need some config or else just tell me,

The first error is about reaching / connecting to Kibana not Elasticsearch during the setup command? Is Kibana running on a different IP address

By the way you want to run the full setup command not just dashboards or you will not get the results you are expecting.

Just run

filebeat setup -e

The output test only test connectivity to Elasticsearch

BTW posting screenshots is discouraged as they are hard to read cannot be searched and others may not even be able to view them in the future please post them as text.

I'm currently facing the similar problem. I'm getting data from filebeat to Elasticsearch and logs are coming and can be found in "discovery" which is great -) but I can't use the dashboard -(. Filebeat succesfully installed dashboads in Kibana but the shows nothing - "No results found". I use cisco module in filebeat and cisco asa dashboard. I've spent 3 days and nights solving this issue please assist -). Thank you in advance

Hi @titan_tm welcome to the community.

First I would open a separate thread with with title like.

Cannot get Cisco Filebeat module to work.

Then in order for us to help you you will need to post your filebeat configurations.

The exact steps you took.

And the show what the data looks like in Discover.

The information you just provided in this thread gives us no information to help you with.

Thanks for your reply. I opened a new topic as you suggested and provided all neccesary info. You can find the topic here in case if you interested -) new topic

Thank you for your support

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.