Filebeat custom module pipeline failed

I build my own filebeat and I created a 'pipeline.yml' in the ingest directory. And I'm surely changed the ingest_pipeline PATH in the mainfest.yml. But when I executed the filebeat but the pipeline processors not worked. Then I checked the pipeline in the dev tool but found my own filebeat pipeline processor not changed. It's still null. So, how could I solve this problem?
2020-09-21 12-03-22 的屏幕截图
2020-09-21 12-08-01 的屏幕截图
2020-09-21 12-08-27 的屏幕截图

I build this filebeat module to collect log. This fileset can collect the log data, but I wanna use the pipeline processors to filter or rename some fields.

I never created a filebeat myself but by reading this doc I think you should configure your manifest like this:

ingest_pipeline: ingest/pipeline.json
input: config/testfileset.yml

so I think you should change - ingest/pipeline.yml to - ingest/pipeline.json

also you could create an ingest pipeline inside elasticsearch and tell you index(or inside your index template settings) to use that pipeline.

yeah, I tried to use pipeline.yml and pipeline.json both. But all failed to work.
It's not appropriate to create ingest pipeline inside Elasticsearch cause I will try to buid another more custom filebeats or filesets in my codes.
Maybe I use some wrong configuration?

I create another filebeat module and It works good.
Maybe some configs wrong. It's really funny. :sweat_smile:

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.