Ingest Pipeline does not update on filebeat setup


(Joakim Uddholm) #1

I'm trying to develop two new modules for filebeat, but ran into issues as I was trying to update my pipelines after some trial and error. It seems like they don't update like they should, so this could be a potential issue in filebeat.

A previous topic suggested running filebeat setup. I did this, but had no effect.

The create a module tutorial also suggests running filebeat setup --pipelines to force the update, but this also made no difference.

I managed to get my updated pipelines and get my modules working eventually by manually sending the pipeline via the dev console in kibana (using the ingest api).

Version: 6.3.2 (based off the 6.3.2 tag on github repo).


(Noémi Ványi) #2

Pipelines of enabled modules are loaded only by Filebeat. Have you enabled you module in the config or during setup?

You could run:

./filebeat setup -pipelines -modules="{{ your-module-name }}"

(Joakim Uddholm) #3

Thanks for the quick reply!

I tried it in the config, but on a server where the module was enabled in a /etc/filebeat/modules.d/ directory. I did load a config locally too, to talk with my elasticsearch instance, but did not try explicitly enabling the module. I'll try it.


(Joakim Uddholm) #4

It worked! I think my error then was not explicitly enabling the new modules via the -modules option.


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.