Filebeat docker image build failure


#1

I tried to build filebeat docker container image from this repo
https://github.com/elastic/beats-docker.

I ended up with this.

Step 4 : RUN curl -Lso - https://artifacts.elastic.co/downloads/beats/auditbeat/auditbeat-7.0.0-alpha1-linux-x86_64.tar.gz | tar zxf - -C /tmp && mv /tmp/auditbeat-7.0.0-alpha1-linux-x86_64 /usr/share/auditbeat
---> Running in e64e1ab4e27b

gzip: stdin: not in gzip format
tar: Child returned status 1
tar: Error is not recoverable: exiting now
The command '/bin/sh -c curl -Lso - https://artifacts.elastic.co/downloads/beats/auditbeat/auditbeat-7.0.0-alpha1-linux-x86_64.tar.gz | tar zxf - -C /tmp && mv /tmp/auditbeat-7.0.0-alpha1-linux-x86_64 /usr/share/auditbeat' returned a non-zero code: 2
Makefile:51: recipe for target 'auditbeat' failed
make: *** [auditbeat] Error 2

The reason is the broken links like
https://artifacts.elastic.co/downloads/beats/auditbeat/auditbeat-7.0.0-alpha1-linux-x86_64.tar.gz

Do you support this repo?


(Carlos Pérez Aradros) #2

You should probably use a different branch, we use master for next releases, so auditbeat-7.0.0 is not yet released. Have a look to branches and choose the one you are interested on. For latest non-production release (6.0.0-rc2) use 6.0 branch


#3

Sorry, I forgot to say that I tried 6.x, 6.0 they doesn't work. But today I've found out that 5.6 works fine. Is this the latest version of the filebeat?


(Maxime Gréau) #4

Hi @4xy

The 6.0.0-rc2 version has not been released yet that's why the "default" build on the 6.0 branch doesn't work.

So, you can use the ELASTIC_VERSION to set the version that you want to build, for example

 git checkout -b 6.0 origin/6.0
 ELASTIC_VERSION=6.0.0-rc1 make

Then the build should work (all tests should succeed and the beats images available locally)

...
tests/test_user.py::test_group_properties[docker://packetbeat] PASSED
tests/test_user.py::test_user_properties[docker://packetbeat] PASSED
===============================================================================================
 115 passed in 71.20 seconds 
===============================================================================================

$ docker images
REPOSITORY                                      TAG                 IMAGE ID            CREATED             SIZE
docker.elastic.co/beats/packetbeat              6.0.0-rc1           d7d314c42abb        3 minutes ago       414MB
docker.elastic.co/beats/metricbeat              6.0.0-rc1           10171a959507        3 minutes ago       474MB
docker.elastic.co/beats/heartbeat               6.0.0-rc1           8ca424dc2170        3 minutes ago       390MB
docker.elastic.co/beats/filebeat                6.0.0-rc1           693febdf0ade        4 minutes ago       348MB
docker.elastic.co/beats/auditbeat               6.0.0-rc1           04f25d20ec01        4 minutes ago       345MB

I hope that helps you.


(system) #5

This topic was automatically closed after 21 days. New replies are no longer allowed.