Filebeat Doesn't open port 5066

Hello there.
I'm facing a problem i cannot resolve.
I' using filebeat for shipping elasticsearch, kibana and logstash logs and i also use metricbeat for monitor them.
In filebeat.yml i have "http.enabled: true" to open port 5066 for monitoring.
Today i switched from elasticsearch.output to logstash.output cause i want to put the output in elasticsearch and at the same time store the raw logs on my system (on a NFS) for back up (test for future winlogbeat deploy), but after setting up logstash.output and setting up the pipeline, when i do a netstat -antp | grep 5066 i don't see the open port, nor i see the beat on kibana's stack monitoring.
Is this a bug? Is there any other method to send logs to elasticsearch and to a file without logstash? Or am i missing some configuration so it can't open tcp/5066?
Thank you.

I got the port open adding to the filebeat.yml
http.host: localhost and http.port: 5066
I was running the same issue in metricbeat, and i was using http.port: 5067, so i think binding to localhost did the trick, but on stack monitoring (kibana) i cannot see filebeat with the other beats..

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.