Filebeat exclude lines with multiline


Is there any way we can exclude the lines first before splitting the logs via multiline pattern?
I have one specific logs with 3 different log patterns, the problem is, the output is incorrect due the extra lines

Here's my config

this is how it looked like in kibana

Without the extraline, the pattern should work

Hey @inhinyera16,

Take a look to the filestream input and its parsers option. It allows to select on what order multiline and other parsing options happen.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.