Filebeat failed to load config file - no such file


#1

I've been trying to befriend Elastic Stack but so far it's not liking me, I guess.

I've scrolled through the forum, however, I did not find any post with the same issue. I'm sure it's simple but I can't figure out.

So, whenever I try to run ./filebeat or ./filebeat -configtest -e it throws the error below.

-bash$ ./filebeat -configtest -e
Exiting: error loading config file: open filebeat.yml: no such file or directory

I thought it was installation error, so I tried to install Filebeat on two different machines and both times it gives me the same error. I used repository to install. I'm assuming I'm making a mistake in the installation process, even though all of the directories are where they supposed to be.

Thanks for the help in advance


(Maddin2016) #2

Hi @Rinat, is the filebeat.yml present at your installation folder?


#3

I confirmed that it is present in /etc/filebeat. Is that what you are referring to? I also check the file itself and only made changes for Logstash output.


(Maddin2016) #4

Can you please try -c path_to_filebeat.yml


#5

If I do ./filebeat -c path_to_filebeat.yml it just hangs on empty output and does not do anything. Am I using the wrong command?

Thanks for your help!


(Maddin2016) #6

please try ./filebeat -c path_to_yml -e -d "*" and post the output.


(Maddin2016) #7

But i think it was the missing -c switch. If there is no output it seems to running.


#8

Ok, thanks. It worked better. I could see logs which is a good thing. However, now I'm having a different issue. In the debug message, one came up as ERR stating that Harvester could not open some of the files - permission denied. Which isn't a problem. But I don't know what this one is : 2017/01/07 17:14:09.899275 registrar.go:297: ERR Failed to create tempfile (/usr/share/filebeat/bin/data/registry.new) for writing: open /usr/share/filebeat/bin/data/registry.new: permission denied. Do I have to explicitly grant permissions to that file?


(Maddin2016) #9

you can set the path.data location to a path where you have permission to write to. See here. Otherwise you have to change the permissions for the default path for your account under which fiebeat is running.


(Maddin2016) #10

Also look here for the part registry_file


#11

Great! Thanks a lot for your help. Besides those secondary things, it appears to be working. And as I suspected it was something as simple as declaring path to the file.


(Maddin2016) #12

Fine to hear it works now!


#13

Thanks again. I still have a long way to go. Trying to learn and implement Elastic Stack from ground 0. And it's like every new step I have to conduct a research))).
I'm glad there is very helpful community over here!


(Maddin2016) #14

Thanks for that feedback! :thumbsup: Should you have any further questions do not hesitate to ask!


(system) #15

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.