Filebeat high read io when collecting log data

I have a Filebeat setup to collect log data in SATA, but it does have a high read IO of around 20mb/s. below is my Filebeat config, it outputs to Kafka cluster. im just wondering is there any way to slow down the Filebeat collecting rate to reduce the read IO on disk? or any config that I can make to lower the IO?

  type: log
  encoding: plain
  scan_frequency: 3s
    - /usr/share/filebeat/logs/*/*.log
    - /usr/share/filebeat/logs/*/*.error
  fields_under_root: true
  multiline.pattern: '^[0-9]{4}-[0-9]{2}-[0-9]{2}'
  multiline.negate: true
  multiline.match: after
  multiline.timeout: 5s
  tail_files: false
  symlinks: false
  backoff: 1s
  max_backoff: 10s
  backoff_factor: 2
  harvester_limit: 0
  ### Harvester closing options
  close_inactive: 20m
  close_renamed: false
  close_removed: false
  close_eof: false
  close_timeout: 0
  ### State options
  clean_inactive: 0
  clean_removed: true
  enabled: true
  hosts: '${KAFKA_HOSTS:kafka:9092}'
  topic: 'topic'
    reachable_only: true

Check this and this

I would try to set values next params and test:

  events: 4096
  flush.min_events: 512
  flush.timeout: 5s

sure, ill give it a try.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.