Filebeat - IIS Module - No geopoint


(Mudasar Ellahi) #1

Hi everyone,

I am trying to send IIS logs of one server to elasticsearch for which I am using Filebeat IIS module.

I am able to send IIS logs to elasticsearch directly only problem is Index mapping, I have location field which is mapped as iis.access.geoip.location.lat number and iis.access.geoip.location.lon number instead of iis.access.geoip.location as geopoint due to which I am unable to map it in Visualization

I have changed default index name in filebeat.json

image

When I run .\filebeat setup it creates meta-* index with iis.access.geoip.location as geopoint but when I transfer IIS logs this index is overwritten and iis.access.geoip.location is removed in result.


(Andrew Kroh) #2

Please share your Filebeat configuration. Use the </> code button to preserve the indentation on the data.


(Mudasar Ellahi) #3
#=========================== Filebeat inputs =============================

filebeat.inputs:

# Each - is an input. Most options can be set at the input level, so
# you can use different inputs for various configurations.
# Below are the input specific configurations.

- type: log

  # Change to true to enable this input configuration.
  enabled: true

  # Paths that should be crawled and fetched. Glob based paths.
  paths:
    - C:\Ejazahlogs\*.log
  fields:
    type: "live_meta_fb_log"
  document_type: JSON
  json.keys_under_root: true
  json.add_error_key: true
  scan_frequency: 30s
  encoding: utf8

filebeat.shutdown_timeout: 30s
#============================= Filebeat modules ===============================

filebeat.config.modules:
  # Glob pattern for configuration loading
  path: ${path.config}/modules.d/*.yml

  # Set to true to enable config reloading
  reload.enabled: true

  # Period on which files under path should be checked for changes
  #reload.period: 10s

#==================== Elasticsearch template setting ==========================

setup.template.settings:
  index.number_of_shards: 1
  index.codec: best_compression
  #_source.enabled: false

#================================ General =====================================

# The name of the shipper that publishes the network data. It can be used to group
# all the transactions sent by a single shipper in the web interface.
name:

# The tags of the shipper are included in their own field with each
# transaction published.
#tags: ["service-X", "web-tier"]

# Optional fields that you can specify to add additional information to the
# output.
fields:
  env: meta


#============================== Dashboards =====================================
# These settings control loading the sample dashboards to the Kibana index. Loading
# the dashboards is disabled by default and can be enabled either by setting the
# options here, or by using the `-setup` CLI flag or the `setup` command.
setup.dashboards.enabled: false
# The URL from where to download the dashboards archive. By default this URL
# has a value which is computed based on the Beat name and version. For released
# versions, this URL points to the dashboard archive on the artifacts.elastic.co
# website.
#setup.dashboards.url:

#============================== Kibana =====================================

# Starting with Beats version 6.0.0, the dashboards are loaded via the Kibana API.
# This requires a Kibana endpoint configuration.
setup.kibana:

  # Kibana Host
  # Scheme and port can be left out and will be set to the default (http and 5601)
  # In case you specify and additional path, the scheme is required: http://localhost:5601/path
  # IPv6 addresses should always be defined as: https://[2001:db8::1]:5601
  host: "10.0.1.63:5601"
  

#============================= Elastic Cloud ==================================

# These settings simplify using filebeat with the Elastic Cloud (https://cloud.elastic.co/).

# The cloud.id setting overwrites the `output.elasticsearch.hosts` and
# `setup.kibana.host` options.
# You can find the `cloud.id` in the Elastic Cloud web UI.
#cloud.id:

# The cloud.auth setting overwrites the `output.elasticsearch.username` and
# `output.elasticsearch.password` settings. The format is `<user>:<pass>`.
#cloud.auth:

#================================ Outputs =====================================

# Configure what output to use when sending the data collected by the beat.

#-------------------------- Elasticsearch output ------------------------------
output.elasticsearch:
  # Array of hosts to connect to.
   hosts: ["10.0.1.63:9200"]
   index: "%{[fields.type]:meta}-%{+yyyy.MM.dd}"
  # Optional protocol and basic auth credentials.
  #protocol: "https"
  #username: "elastic"
  #password: "changeme"
#============================== Template =====================================

# A template is used to set the mapping in Elasticsearch
# By default template loading is enabled and the template is loaded.
# These settings can be adjusted to load your own template or overwrite existing ones.

# Set to false to disable template loading.
setup.template.enabled: true

# Template name. By default the template name is "filebeat-%{[beat.version]}"
# The template name and pattern has to be set in case the elasticsearch index pattern is modified.
setup.template.name: "meta-%{+yyyy.MM.dd}"

# Template pattern. By default the template pattern is "-%{[beat.version]}-*" to apply to the default index settings.
# The first part is the version of the beat and then -* is used to match all daily indices.
# The template name and pattern has to be set in case the elasticsearch index pattern is modified.
setup.template.pattern: "meta-%{+yyyy.MM.dd}-*"

# Path to fields.yml file to generate the template
setup.template.fields: "${path.config}/fields.yml"

# Overwrite existing template
setup.template.overwrite: true

#----------------------------- Logstash output --------------------------------
#output.logstash:
  # The Logstash hosts
  #hosts: ["localhost:5044"]

  # Optional SSL. By default is off.
  # List of root certificates for HTTPS server verifications
  #ssl.certificate_authorities: ["/etc/pki/root/ca.pem"]

  # Certificate for SSL client authentication
  #ssl.certificate: "/etc/pki/client/cert.pem"

  # Client Certificate Key
  #ssl.key: "/etc/pki/client/cert.key"

#================================ Logging =====================================

# Sets log level. The default log level is info.
# Available log levels are: error, warning, info, debug
#logging.level: debug

# At debug level, you can selectively enable logging only for some components.
# To enable all selectors use ["*"]. Examples of other selectors are "beat",
# "publish", "service".
#logging.selectors: ["*"]

(Andrew Kroh) #4

You have:

output.elasticsearch.index: "%{[fields.type]:meta}-%{+yyyy.MM.dd}"
setup.template.name: "meta-%{+yyyy.MM.dd}"
setup.template.pattern: "meta-%{+yyyy.MM.dd}-*"

Your issue is with the template not being applied to your indices because the pattern doesn't match the index names. You should not use the date patterns in the setup.template.* config values. Additionally, any indices not specifically beginning with meta will not have a template applied either (separate problem).

So if you try something like this I think it should work:

output.elasticsearch.index: "%{[fields.type]:meta}-%{+yyyy.MM.dd}"
setup.template.name: "meta"
setup.template.pattern: "meta-*"

But I recommend keeping the beat version value contained in your index names so that upgrading versions is easier in the future.

output.elasticsearch.index: "filebeat-%{[beat.version]}-%{[fields.type]:meta}-%{+yyyy.MM.dd}"
setup.template.name: "filebeat-%{[beat.version]}"
setup.template.pattern: "filebeat-%{[beat.version]}-*"

(Mudasar Ellahi) #5

Thanks a lot. It worked perfectly.


(system) #6

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.