Filebeat index exists but Dashboard says no

I have a fresh install of Elasticsearch and Kibana on the same box. They are version 7.5.2.

I have a filebeat-* index and when I go to that index I see my logs. However, when I go to any of the default filebeat dashboards it says:

Could not locate that index-pattern (id: filebeat-*), [click here to re-create it](#/management/kibana/index_pattern)

Any ideas?



Hi @gungazoo! I'm not sure how you're seeing your logs for filebeat-*, are you viewing them in Discover? If so, it's indeed strange that nothing displays in Dashboard. Are you able to view your logstash docs in Dashboard?

Sorry, I should have put that. Yes -- I'm seeing them in Discover.

Thanks for the help @cheiligers

I haven't tried to make any dashboards for Logstash yet. The default dashboards that include the name Logstash are still based on the filebeat index.

I just looked at a metricbeat dashboard and some of the panels show up and some don't. And, FWIW, I tried deleting the index-pattern and re-creating it.

Anyone have any thoughts?

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.