Filebeat is not sending data to Elasticsearch

I have a standard Ubuntu 17.10 installation.
I've installed elasticsearch, kibana and filebeat.
Filebeat is processing data from a log file named fuse.log, but it is not sending it to Elasticsearch.
I'm not sure where it is sending it...

Log output:

Here is my /etc/filebeat/filebeat.yml:

#=========================== Filebeat prospectors =============================


# Each - is a prospector. Most options can be set at the prospector level, so
# you can use different prospectors for various configurations.
# Below are the prospector specific configurations.

- type: log

  # Change to true to enable this prospector configuration.
  enabled: true

  # Paths that should be crawled and fetched. Glob based paths.
    - /home/sindre/Temp/FileBeatInput/*.log
    #- c:\programdata\elasticsearch\logs\*

#============================= Filebeat modules ===============================

  # Glob pattern for configuration loading
  path: ${path.config}/modules.d/*.yml

  # Set to true to enable config reloading
  reload.enabled: false

  # Period on which files under path should be checked for changes
  #reload.period: 60s

#==================== Elasticsearch template setting ==========================

  index.number_of_shards: 3
  #index.codec: best_compression
  #_source.enabled: false

# Starting with Beats version 6.0.0, the dashboards are loaded via the Kibana API.
# This requires a Kibana endpoint configuration.

  # Kibana Host
  # Scheme and port can be left out and will be set to the default (http and 5601)
  # In case you specify and additional path, the scheme is required: http://localhost:5601/path
  # IPv6 addresses should always be defined as: https://[2001:db8::1]:5601
host: "localhost:5601"

#================================ Outputs =====================================

# Configure what output to use when sending the data collected by the beat.

#-------------------------- Elasticsearch output ------------------------------
  # Array of hosts to connect to.
  hosts: ["localhost:9200"]

  # Optional protocol and basic auth credentials.
  #protocol: "https"
  #username: "elastic"
  #password: "changeme"

The part of the log you shared all looks normal. Why do you think the data does not arrive on the Elasticsearch side?

I managed to get it working.
It was the user owner of the folders in Linux.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.