Filebeat not connecting to ES


(SUDHAKAR) #1

I know this has been discussed quite a few times but would really appreciate the help on this as I have went through all the solutions but none of them would work.

Filebeat service is not connecting to ES for direct output.

This is what I have done:

1: Kibana is running and I able to connect metricbeat,heartbeat and auditbeat vis ES.
2: Filebeat is also running as a service but when I put the index pattern "filebeat-*" in kibana it says not matching pattern found.

I have used the command : "curl http://localhost:9200/_cat/indices?v"

But I dont see any entry for Filebeat.

3: I used the command to export the template file: " .\filebeat.exe export template --es.version 6.1.1 | Out-File -Encoding UTF8 filebeat.template.json "

Then used the below command to install it in kibana:

" Invoke-RestMethod -Method Put -ContentType "applicat
ion/json" -InFile filebeat.template.json -Uri http://localhost:9200/_template/filebeat-6.0.1"

output:
acknowledged

    True

Below is the filebeat.yml file, everything is default and i have changed nothing.

Please help !

Thanks
SUDHAKAR


(Steffen Siering) #2

Please format logs, scripts and other text using the </>-Button.

Please no images of config or log output :slight_smile:

Have you checked the filebeat log file? Disable service and try running filebeat in foreground (in Terminal):

filebeat.exe -c <path-to-config-file> -e -v

(SUDHAKAR) #3

Hi Steffens,

Thanks for your quick reply:slight_smile:.

Will take care for your suggestions .

Yes I did try to execute the service from windows terminal. But does not shows the connectivity log with ES in cmd.

I did check the logs for filebeat while running it as a service. WHat I find different is in other beats I see logging which says connected to ES but in filebeat I dont see that.

Any idea?

Thanks,
SUDHAKAR


(Steffen Siering) #4

Can you please share the log output?


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.