Filebeat not detecting log files

Hi,

I am setting my filebeat on Windows, but for somehow it did not detect the files in the path I configured in filebeat.yml.
I do have .log files in c:\var\logs\oob-demo\ , but apparently those were not detected.
Anyone has an idea why log file not detected?
In fact, such dir is not shown in log file. How do I know that filebeat has checked that location and have 0 result?

filebeat.yml:

filebeat.inputs:

  • type: log
    enabled: false
    paths:
    • c:\var\logs\oob-demo*.log
      multiline.pattern: ^[[:digit:]]{4}-[[:digit:]]{2}-[[:digit:]]{2}
      multiline.negate: true
      multiline.match: after

filebeat.config.modules:
path: ${path.config}/modules.d/*.yml
reload.enabled: false

setup.template.settings:
index.number_of_shards: 3

setup.kibana:
host: "192.168.1.79:5601"

output.elasticsearch:
hosts: ["192.168.1.79:9200"]

filebeat log:

2018-08-10T16:04:18.614-0400 INFO instance/beat.go:492 Home path: [C:\Program Files\Filebeat] Config path: [C:\Program Files\Filebeat] Data path: [C:\Program Files\Filebeat\data] Logs path: [C:\Program Files\Filebeat\logs]
2018-08-10T16:04:18.629-0400 INFO instance/beat.go:499 Beat UUID: 9edb394a-4044-4fab-be0f-23f0c0812370
2018-08-10T16:04:18.629-0400 INFO [beat] instance/beat.go:716 Beat info {"system_info": {"beat": {"path": {"config": "C:\Program Files\Filebeat", "data": "C:\Program Files\Filebeat\data", "home": "C:\Program Files\Filebeat", "logs": "C:\Program Files\Filebeat\logs"}, "type": "filebeat", "uuid": "9edb394a-4044-4fab-be0f-23f0c0812370"}}}
2018-08-10T16:04:18.629-0400 INFO [beat] instance/beat.go:725 Build info {"system_info": {"build": {"commit": "45a9a9e1561b6c540e94211ebe03d18abcacae55", "libbeat": "6.3.2", "time": "2018-07-20T04:17:39.000Z", "version": "6.3.2"}}}
2018-08-10T16:04:18.629-0400 INFO [beat] instance/beat.go:728 Go runtime info {"system_info": {"go": {"os":"windows","arch":"386","max_procs":2,"version":"go1.9.4"}}}
...
2018-08-10T16:04:18.629-0400 INFO instance/beat.go:225 Setup Beat: filebeat; Version: 6.3.2
2018-08-10T16:04:18.629-0400 INFO elasticsearch/client.go:145 Elasticsearch url: http://192.168.1.79:9200
2018-08-10T16:04:18.629-0400 INFO pipeline/module.go:81 Beat name: ws-server0
2018-08-10T16:04:18.629-0400 INFO instance/beat.go:315 filebeat start running.
2018-08-10T16:04:18.629-0400 INFO registrar/registrar.go:117 Loading registrar data from C:\Program Files\Filebeat\data\registry
2018-08-10T16:04:18.629-0400 INFO registrar/registrar.go:124 States Loaded from registrar: 0
2018-08-10T16:04:18.629-0400 INFO [monitoring] log/log.go:97 Starting metrics logging every 30s
2018-08-10T16:04:18.629-0400 INFO crawler/crawler.go:48 Loading Inputs: 1
2018-08-10T16:04:18.629-0400 INFO crawler/crawler.go:82 Loading and starting Inputs completed. Enabled inputs: 0
2018-08-10T16:04:18.629-0400 INFO cfgfile/reload.go:122 Config reloader started
2018-08-10T16:04:18.629-0400 INFO cfgfile/reload.go:214 Loading of config files completed.
2018-08-10T16:04:48.651-0400 INFO [monitoring] log/log.go:124 Non-zero metrics in the last 30s {"monitoring": {"metrics": {"beat":{"cpu":{"system":{"ticks":62,"time":{"ms":62}},"total":{"ticks":93,"time":{"ms":93},"value":93},"user":{"ticks":31,"time":{"ms":31}}},"info":{"ephemeral_id":"a0f6cb82-c970-4198-b55b-543bb0100432","uptime":{"ms":30099}},"memstats":{"gc_next":4473924,"memory_alloc":1929640,"memory_total":1929640,"rss":12083200}},"filebeat":{"harvester":{"open_files":0,"running":0}},"libbeat":{"config":{"module":{"running":0},"reloads":1},"output":{"type":"elasticsearch"},"pipeline":{"clients":0,"events":{"active":0}}},"registrar":{"states":{"current":0}},"system":{"cpu":{"cores":2}}}}}

Thanks.

Two things are wrong in the configuration you pasted:

filebeat.inputs:
- type: log
  enabled: false
  paths:
  - c:\var\logs\oob-demo*.log

Change it to:

filebeat.inputs:
- type: log
  enabled: true
  paths:
  - c:\var\logs\oob-demo\*.log
1 Like

Success!! Thanks Adrisr.
Question: Why remove backword-slash () in the path? Is that an escape character? FYI "oob-demo" is a folder.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.