Filebeat not starting at startup

I've installed Filebeat on an Ubuntu 16.04 server (AWS EC2) according to the instructions here, including running

sudo update-rc.d filebeat defaults 95 10

However, I still have to run

sudo service filebeat start

to start filebeat. Is that behaviour expected or am I doing something wrong?

On Ubuntu 16.04, which is using systemd, you need to do: systemctl enable filebeat instead of the update-rc.d command.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.