Starting Beats on bootup with SystemD

I believe I've found a problem where the default install of a Beat on a Linux system that uses Systemd, it won't register itself properly to be enabled at startup. I'm not super familiar with Systemd please forgive me if I've missed something obvious to others.

I'm running Elasticsearch Cloud on AWS and Nginx on a Lightsail instance. I followed the getting started steps to the letter and everything worked as expected until I rebooted the instance. My Kibana dashboard went quiet. Manually restarting the file/metricbeat service with sudo service filebeat start got it going again but it still wouldn't come back after a reboot (including a full stop start cycle). In the end I got it working by issuing sudo systemctl enable filebeat. I have both filebeat and metricbeat installed and they both behaved in exactly the same way.

Kibana 6.7.0
Ubuntu SMP for Lightsail - 16.04.5 LTS

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.