Filebeat on Kubernetes setup pipelines

We are using filebeat in kubernetes to output to logstash. In order for the modules we use to be correctly parsed via pipelines and ingest nodes this needs to be enabled somehow but currently i see no way to pass it or enable it inside filebeat.yaml.

This is needed to pass the %{[@metadata][pipeline]}] to logstash so that it is parsed correctly inside elasticsearch. What is the correct way to do this or is it even possible?

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.