Filebeat resend the harvested log many times


#1

I have filebeat sending logs to logstash on AWS, but it's not getting any feedback from logstash, and it resend the files over and over,
here is the error msg from Preformatted textilebeat logs ,
Filebeat version 6.3.2
Filebeat Configuration:

type: log
timeout: 1
# Change to true to enable this prospector configuration.
enabled: true
# Paths that should be crawled and fetched. Glob based paths.
paths:
-AAA\*.log
 close_inactive: true
 close_eof: true
#================================ Outputs =====================================
#----------------------------- Logstash output --------------------------------

hosts: ["awscloud.com:5044"]

logstash input configurations:

  input {
    beats {
	    port => 5044
	     client_inactivity_timeout => 5400
    }
}


(Steffen Siering) #2

Beats need the ACK signal from Logstash. Check network/firewall rules.

Which logstash version are you using?

The timeout is in beats, but the default timeout is like 30s, while Logstash sends a keep-alive signal like every 5s.


#3

Thanks a lot for your reply,,
I'm using Logstash V6.3.2
can I disable the ACK for the logstash ?
I will update the timeout,


(Steffen Siering) #4

No, the ACK can not be disabled. It is required so filebeat knows logs have been actually transmitted.


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.