Filebeat.yml ignoring path.home

I am running Filebeat 6.2.4 on my local Mac OS, installed via Homebrew.

When I run FB, it ignores my path.home declaration in my filebeat.yml file. However, I can verify that yml is being parsed and read, because if I include an error in it, startup fails with appropriate error message. To get FB to recognize my home path, I have to pass it in as CLI variable.


path.home: /usr/local/etc/filebeat

filebeat -e
2018-08-09T21:12:49.253-0700 INFO instance/beat.go:468 Home path: [/usr/local/Cellar/filebeat/6.2.4] Config path: [/usr/local/etc/filebeat] Data path: [/usr/local/var/lib/filebeat] Logs path: [/usr/local/var/log/filebeat]
2018-08-09T21:12:49.254-0700 INFO instance/beat.go:475 Beat UUID: 2b058feb-772a-4bd1-abd7-4137e2d4bbe3
2018-08-09T21:12:49.254-0700 INFO instance/beat.go:213 Setup Beat: filebeat; Version: 6.2.4
2018-08-09T21:12:49.255-0700 INFO elasticsearch/client.go:145 Elasticsearch url: http://localhost:9200
2018-08-09T21:12:49.256-0700 INFO pipeline/module.go:76 Beat name: hero-c02rg00ug8wq.lan
2018-08-09T21:12:49.256-0700 ERROR fileset/modules.go:95 Not loading modules. Module directory not found: /usr/local/Cellar/filebeat/6.2.4/module

I just tried this out on my mac and was able to reproduce it. If you have a GitHub account, would you mind reporting this bug in the beats repo here: That way you will be notified of any progress on the bug as well.

If you don't have a GitHub account, let me know and I'll file the issue for you.

Yes, I will do that today , thanks Shaunak.

  • tom

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.