Filter Plugin - "Tried to load a plugin's code, but failed."

Hi there,
there is a logstash filter plugin called elapsed.

I put (also) this into a config:
elapsed {
unique_id_field => "reqid"
start_tag => "TranBegin"
end_tag => "TranEnd"
new_event_on_match => false
and made just for a test:

bin/logstash -f /home/m0001637/test/logstash-7.8.1/config/logstash2.conf --config.test_and_exit

The result was:
[2020-12-21T06:55:20,407][ERROR][logstash.plugins.registry] Tried to load a plugin's code, but failed. {:exception=>#<LoadError: no such file to load -- logstash/filters/elapsed>, :path=>"logstash/filters/elapsed", :type=>"filter", :name=>"elapsed"}
[2020-12-21T06:55:20,415][FATAL][logstash.runner ] The given configuration is invalid. Reason: Unable to configure plugins: (PluginLoadingError) Couldn't find any filter plugin named 'elapsed'. Are you sure this is correct? Trying to load the elapsed filter plugin resulted in this error: no such file to load -- logstash/filters/elapsed
[2020-12-21T06:55:20,419][ERROR][org.logstash.Logstash ] java.lang.IllegalStateException: Logstash stopped processing because of an error: (SystemExit) exit

Why so? Logst. could not find that filter, but such filter does exist if you see the documentation. I am running 7.8.1.

Any help is appraciated.

Found the reason: it is not a deafult plugin.
bin/logstash-plugin install logstash-filter-elapsed

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.