Filtering different indexes with missing field


(Tiago Lima) #1

Hi,

I'm trying to filtering two different indexes with the same filter, but one
of the indexes doesn't have the field that I'm trying to filter:

"mappings":{
"user":{
"properties":{
"inactive":{
"type":"boolean",
"index":"not_analyzed"
}
}
}
},
"course":{
"properties":{
}
}
}

Filtering:
"filter":{
"and":[
{ },
{
"term":{
"inactive":false
}
}
]
},

But only users is retrieved, how can I apply this filter just for user
index.

I really appreciate any help.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/9c5be39f-b1ab-4cf8-8b11-cca365cd228d%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Tiago Lima) #2

I got the answer, I just have to use the missing filter:
http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/query-dsl-missing-filter.html

Tiago Ferreira Lima

GitHub: fltiago
Skype: fltiago
LinkedIn: linkedin.com/in/fltiago

On Wed, Jul 16, 2014 at 11:16 AM, Tiago Lima fltiago@gmail.com wrote:

Hi,

I'm trying to filtering two different indexes with the same filter, but
one of the indexes doesn't have the field that I'm trying to filter:

"mappings":{
"user":{
"properties":{
"inactive":{
"type":"boolean",
"index":"not_analyzed"
}
}
}
},
"course":{
"properties":{
}
}
}

Filtering:
"filter":{
"and":[
{ },
{
"term":{
"inactive":false
}
}
]
},

But only users is retrieved, how can I apply this filter just for user
index.

I really appreciate any help.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/s5eBefaebP0/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/9c5be39f-b1ab-4cf8-8b11-cca365cd228d%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/9c5be39f-b1ab-4cf8-8b11-cca365cd228d%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAFRafxPNRt5nUwvz8NRJoi7%2B-vzi5v2kM8C7Gs9CTWXegbot4g%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(system) #3