Firewall blocking icmp

i have my ELK cluster working fine, but i would like to get rid of some error messages found in the log file.

one of them is this one:

2016-06-30 22:21:25,815[INFO ][discovery.zen ] [elastic-node-202-174] master_left [{elastic-node-30-161}{5WrNrcy-VygOw}{}{}], reason [failed to ping, tried [3] times, each with maximum [30s] timeout]

i know that my company firewall is blocking icmp reply (we can't ping servers in different networks).

so, what config should i change make this message go away?

There's nothing you can do.

can i disable ping?

or make it ping once every 6 hours?

The pinging done by ES is not based on ICMP but uses the same protocol as for all other kinds of inter-node communication (TCP). The log warning indicates that the master node was not reachable from this node for 90 seconds. Maybe the master was down for a while or there are connection issues in your network?

i have 2 elk nodes on network and 2 more on network
i only see these lines when the communication is between networks.

when on the same, there are no problems.
thats why i suspected it was the firewall blocking the ping.

now, since it is a tcp ping, and i know that i can telnet on ports 9200:9300 without any problem, i'm kind of lost...