Force filebeat to reparse CSV


I'm using filebeat and Logstash I want to force re-parse the files provided in the path section, but that doesn't seem to work

my config filebeat is:


- type: log
  enabled: true

     - /data/volumes/monitoring/logstash/logCtrlM/stocks.csv

exclude_lines: ['^chaine']

  hosts: ["logstash:5044"]
1 Like

There's no "reparse" option in Filebeat. However, you can delete the data folder where Filebeat stores the metadata which will force reparse of everything

The data folder is the registry file beat?

Yeap, the registry is the one tracking the position of the "reading cursor" on the files.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.