Found cloud much slower that a local instance


We are experiencing very slow document indexing speeds in any found cloud instance. These slowdowns are somewhere in the range of 5X. It does seem that shield is a definite factor in this issue.

For example, I tried the following curl across a couple of different ES instances. Below are the results.
curl -XPUT "https://$ELASTICSEARCH_URL/movies/movie/1" -d'{ "title": "The Godfather", "director": "Francis Ford Coppola", "year": 1972 }'

Found Cloud w/ Shield: 1.932s
Fonud Cloud w/o Shield: 0.353s
Localhost: 0.020s

The found instances in this case were simple 1G memory machines, but we experience the same thing with our 128G cluster as well.

Any insight into this would be greatly appreciated!

Did you take into account network latency?

I tried out two found cloud instances, the one without shield was a little slower (+.33s) but I am assuming that is up to network latency and ssl negotiation.

The one with shield was another +1.6s, which is quite a jump. Doesn't seem like something I would attribute to network latency.