Frequent OOM


(Andrey Perminov) #1

We are running es 1.2.1 cluster on 4 nodes: 4 cores, 14 GB RAM, 1.5 TB disk
space, swap disabled.
Our application creates daily indexes 2 up to 12 GB in size. No sharding, 1
replica. Currently 200+ indexes (~1.2 TB data). Heap size is set to 6 GB.
The main problem is that elastic nodes frequentely (once a day or two) eats
up whole system memory and dies. Now it is monitored with monit with
setting to restart node on 90% memory usage. It still fails from time to
time.
Adding new nodes is currently very difficult, so I'm looking for a way to
optimize my current setup. Any suggestions?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/9a1eae4a-85c5-4b40-9223-e00a6ee8fcac%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Andrey Perminov) #2

I've tried to diable bloom filter for older indexes with no luck. I cannot
close indexes, because all of them are used.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/b5d0024a-ab09-493a-85cb-dea86f077add%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Kireet Reddy) #3

Does it seem related to search activity? Merge activity? What does the hot
threads endpoint show before running out of memory? I might try to cap the
max segment size or use more shards so the segments stay less than the heap
size (maybe target 2GB?)

On Wednesday, July 9, 2014 5:00:29 AM UTC-7, Andrey Perminov wrote:

I've tried to diable bloom filter for older indexes with no luck. I cannot
close indexes, because all of them are used.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/924d8dc5-908a-4396-930b-12ed26613ccb%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(system) #4