Full search on a multiple fields request

Hi,

I have a problem with a fullsearch using several columns in a index.
I've tested it in few versions 1.1.x < EL < 1.3.x

Preparation:
(curl -XDELETE 'http://localhost:9200/index1':wink:

curl -XPUT 'http://localhost:9200/index1' -d '
{
"mappings": {
"af": {
"dynamic": "false",
"properties": {
"Attributes": {
"type": "string",
"index": "analyzed",
"null_value": "na"
},
"Desc": {
"type": "string",
"index": "analyzed",
"null_value": "na"
},
"Name": {
"type": "string",
"index": "analyzed",
"null_value": "na"
},
"Type": {
"type": "string",
"index": "analyzed",
"null_value": "na"
},
"Groups": {
"type": "string",
"index": "analyzed",
"null_value": "na"
}
}
}
}
}'

curl -XPOST 'http://localhost:9200/index1/type1' -d '{
"Attributes" : "Att1",
"Name" : "Name1",
"Type" : "Type1",
"Groups" : "Group1",
"Desc" : "Description1"
}'

curl -XGET 'http://localhost:9200/index1/_search' -d '
{
"from": 0,
"size": 15,
"query": {
"bool": {
"must": [
{
"query_string": {
"query": "Name1",
"fields": [
"Name",
"Desc",
"Groups",
"Attributes"
],
"default_operator": "or"
}
}
]
}
},
"filter": {
"terms": {
"Type": [
"Type1",
"Type2"
]
}
}
}'

The Search (tried with GET and POST) request returns 200 without any hit.
{"took":6,"timed_out":false,"_shards":{"total":5,"successful":5,"failed":0},"hits":{"total":0,"max_score":null,"hits":[]}}

Any idea?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CACKXsk%2Bni%2BRf_1qDu1a%3Do31ofxrt6MRrp7NmtXJXG5Tn4rLW1g%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.

I still get zero hits if i write "or" or "and" : "default_operator": "and"

Le dimanche 22 février 2015 17:44:31 UTC+1, Mahyar SEPEHR a écrit :

Hi,

I have a problem with a fullsearch using several columns in a index.
I've tested it in few versions 1.1.x < EL < 1.3.x

Preparation:
(curl -XDELETE 'http://localhost:9200/index1':wink:

curl -XPUT 'http://localhost:9200/index1' -d '
{
"mappings": {
"af": {
"dynamic": "false",
"properties": {
"Attributes": {
"type": "string",
"index": "analyzed",
"null_value": "na"
},
"Desc": {
"type": "string",
"index": "analyzed",
"null_value": "na"
},
"Name": {
"type": "string",
"index": "analyzed",
"null_value": "na"
},
"Type": {
"type": "string",
"index": "analyzed",
"null_value": "na"
},
"Groups": {
"type": "string",
"index": "analyzed",
"null_value": "na"
}
}
}
}
}'

curl -XPOST 'http://localhost:9200/index1/type1' -d '{
"Attributes" : "Att1",
"Name" : "Name1",
"Type" : "Type1",
"Groups" : "Group1",
"Desc" : "Description1"
}'

curl -XGET 'http://localhost:9200/index1/_search' -d '
{
"from": 0,
"size": 15,
"query": {
"bool": {
"must": [
{
"query_string": {
"query": "Name1",
"fields": [
"Name",
"Desc",
"Groups",
"Attributes"
],
"default_operator": "or"
}
}
]
}
},
"filter": {
"terms": {
"Type": [
"Type1",
"Type2"
]
}
}
}'

The Search (tried with GET and POST) request returns 200 without any hit.

{"took":6,"timed_out":false,"_shards":{"total":5,"successful":5,"failed":0},"hits":{"total":0,"max_score":null,"hits":[]}}

Any idea?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/b73e7f94-40c7-428d-9d89-90cffa059a28%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.