Gateway.type issue


(Stecino) #1

Hello,

I am running into this issue when I am restarting my elasticsearch instance on my master node

Stopping elasticsearch: [FAILED]
Starting elasticsearch: [ OK ]

  • elasticsearch-2.1.2]$ Exception in thread "main" java.lang.IllegalArgumentException: Unknown [gateway] type [fs]
    at org.elasticsearch.common.util.ExtensionPoint$SelectedType.bindType(ExtensionPoint.java:146)
    at org.elasticsearch.gateway.GatewayModule.configure(GatewayModule.java:53)
    at <<>>
    at org.elasticsearch.node.Node.(Node.java:200)
    at org.elasticsearch.node.Node.(Node.java:128)
    at org.elasticsearch.node.NodeBuilder.build(NodeBuilder.java:145)
    at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:178)
    at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:285)
    at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:35)
    Refer to the log for complete error details.

This is what's in the log, seems that it still binds to localhost, although I tell it to bind to eth0

[2016-03-01 18:41:48,769][WARN ][bootstrap ] unable to install syscall filter: prctl(PR_GET_NO_NEW_PRIVS): Invalid argument
[2016-03-01 18:41:49,753][INFO ][node ] [Stitch] version[2.1.2], pid[26737], build[63c285e/2016-01-27T12:57:52Z]
[2016-03-01 18:41:49,753][INFO ][node ] [Stitch] initializing ...
[2016-03-01 18:41:50,225][INFO ][plugins ] [Stitch] loaded [], sites []
[2016-03-01 18:41:56,131][INFO ][node ] [Stitch] initialized
[2016-03-01 18:41:56,135][INFO ][node ] [Stitch] starting ...
[2016-03-01 18:41:56,382][INFO ][transport ] [Stitch] publish_address {127.0.0.1:9300}, bound_addresses {127.0.0.1:9300}, {[::1]:9300}
[2016-03-01 18:41:56,411][INFO ][discovery ] [Stitch] herd-dev-wc1/sPweHychTyCwyGDMsV4qnA
[2016-03-01 18:41:58,597][INFO ][node ] [Stitch] stopping ...
[2016-03-01 18:41:58,624][INFO ][node ] [Stitch] stopped
[2016-03-01 18:41:58,624][INFO ][node ] [Stitch] closing ...
[2016-03-01 18:41:58,649][INFO ][node ] [Stitch] closed

Here is what I have in my config:

network.host: "eth0"
gateway.type: local
:


(Mark Walkom) #2

I don't think that is a valid setting in 2.X - https://www.elastic.co/guide/en/elasticsearch/reference/2.1/modules-gateway.html


(Stecino) #3

I removed gateway.type parameter from the yaml file, I am still being prompted for it. Is there anywhere else I need to look for this? Local Gateway is used by a default.


(Stecino) #4

Here is what I have on my startup

/home/t/elasticsearch-2.1.2/bin/elasticsearch -p /home/t/elasticsearch-2.1.2/var/run/elasticsearch.pid -d -Des.default.path.home=/home/t/elasticsearch-2.1.2 -Des.default.path.logs=/home/t/elasticsearch-2.1.2/log -Des.default.path.data=/home/t/elasticsearch-2.1.2/data -Des.default.path.work=/home/t/elasticsearch-2.1.2/tmp -Des.default.path.conf=/home/t/elasticsearch-2.1.2/config'


(Stecino) #5

I solved the issue. I have init script that sets the environment variables for path.
But in the yaml file is overriding with something that was incorrect. Once I fixed it, it came up


(system) #6