GCS Keystore

I have a Google Cloud instance I would like to work with. The GCS plugin is installed but I'm having trouble adding the Google credentials to the Elastic Keystore but I keep getting an error I have not been able to solve or find much about online. Here is the code:

\bin>elasticsearch-keystore add-file gcs.client.default.credentials_file filepath\gcskey.json

A tool for managing settings stored in the elasticsearch keystore

Non-option arguments:

Option Description

-E Configure a setting
-h, --help Show help
-s, --silent Show minimal output
-v, --verbose Show verbose output
ERROR: settings and filenames must come in pairs

I've tried multiple different things but cannot solve this problem to get the GCS creds into the elastic keystore.

Any thoughts?

Welcome to our community! :smiley:

Did you try that with the -v option?

Yes, and I get the same output. I have redownloaded the keys, changed the file path, security settings. I really have no idea what is causing the problem here

So solved it. Don't know exactly what the problem is but I manually deleted the generated keystore and the keystore.tmp. Regenerated the keystore. Put the GCS creds into the keystore and problem solved. Not sure what the problem was but that is all I did

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.