Geo_shape mapping issue


(Alakh Kumar) #1

I am using :
Magento Version : CE Version 2.1
ElasticSuite Version :2.3

when i try to map geo_shape it showing me error message : mapper_parsing_exception: Mapping definition for [coordinates] has unsupported parameters: [norms : {enabled=false}] [doc_values : true]

my code in xml elasticsuite_indices.xml:
field name="hyperlocal.sellerid" type="integer" nestedPath="hyperlocal"
field name="hyperlocal.coordinates" type="geo_shape" nestedPath="hyperlocal"

When i try to index it throwing error message:
mapper_parsing_exception: Mapping definition for [coordinates] has unsupported parameters: [norms : {enabled=false}] [doc_values : true]

what i am missing in mapping xml code?

Expected result
I am trying to mapping like:
"hyperlocal" : {
"type" : "nested",
"properties" : {
"location" : {
"type" : "geo_shape"
},
"sellerid" : {
"type" : "integer"
}
}
}

Please help.


(David Pilato) #2

Please don't post images of text as they are hardly readable and not searchable.

Instead paste the text and format it with </> icon. Check the preview window.


(Alakh Kumar) #3

Thanks for your update. I have also post the text, in image it's easy to understand what's going on.

Can you please help me to fix the geo_shape mapping issue?


(David Pilato) #4

I'm not sure I understand exactly what you are doing or what the software you are using is doing.

Any chance you can share a full script which reproduces your problem?

As described in About the Elasticsearch category. It will help to better understand what you are doing. Please, try to keep the example as simple as possible.

A full reproduction script will help readers to understand, reproduce and if needed fix your problem. It will also most likely help to get a faster answer.


(Alakh Kumar) #5

Thanks for your reply.

I am using elastic smile module for magento. i have fixed it.
I get troubleshoot it and get rid of variables
[norms : {enabled=false}] [doc_values : true] and its working fine.

Thanks


(system) #6

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.