Getting Error in kibana while using xpach

Hi experts,

I am using ELK version 7.12.0.
I have secure my Elasticsearch With Xpack. so that i created http.p12 and elasticsearch-ca.pem
certificates . And I configured it. In that Elasticsearch is working fine. But when I start Kibana , I am Getting this error

log [12:20:06.444] [error][elasticsearch] Request error, retrying
GET https://localhost:9200/_xpack?accept_enterprise=true => self signed certificate in certificate chain
log [12:20:06.507] [warning][elasticsearch] Unable to revive connection: https://localhost:9200/
log [12:20:06.508] [warning][elasticsearch] No living connections
log [12:20:06.510] [warning][licensing][plugins] License information could not be obtained from Elasticsearch due to Error: No Living connections error
log [12:20:06.514] [warning][monitoring][monitoring][plugins] X-Pack Monitoring Cluster Alerts will not be available: No Living connections
log [12:20:06.610] [error][savedobjects-service] Unable to retrieve version information from Elasticsearch nodes.
log [12:20:36.369] [warning][elasticsearch] Unable to revive connection: https://localhost:9200/
log [12:20:36.371] [warning][elasticsearch] No living connections
log [12:20:36.373] [warning][licensing][plugins] License information could not be obtained from Elasticsearch due to Error: No Living connections error
log [12:21:06.383] [warning][elasticsearch] Unable to revive connection: https://localhost:9200/
log [12:21:06.385] [warning][elasticsearch] No living connections
log [12:21:06.386] [warning][licensing][plugins] License information could not be obtained from Elasticsearch due to Error: No Living connections error

My elasticsearch.yml file:

# ======================== Elasticsearch Configuration =========================
#
# NOTE: Elasticsearch comes with reasonable defaults for most settings.
#       Before you set out to tweak and tune the configuration, make sure you
#       understand what are you trying to accomplish and the consequences.
#
# The primary way of configuring a node is via this file. This template lists
# the most important settings you may want to configure for a production cluster.
#
# Please consult the documentation for further information on configuration options:
# https://www.elastic.co/guide/en/elasticsearch/reference/index.html
#
# ---------------------------------- Cluster -----------------------------------
#
# Use a descriptive name for your cluster:
#
#cluster.name: my-application
#
# ------------------------------------ Node ------------------------------------
#
# Use a descriptive name for the node:
#
#node.name: node-1
#
# Add custom attributes to the node:
#
#node.attr.rack: r1
#
# ----------------------------------- Paths ------------------------------------
#
# Path to directory where to store the data (separate multiple locations by comma):
#
#path.data: /path/to/data
#
# Path to log files:
#
#path.logs: /path/to/logs
#
# ----------------------------------- Memory -----------------------------------
#
# Lock the memory on startup:
#
#bootstrap.memory_lock: true
#
# Make sure that the heap size is set to about half the memory available
# on the system and that the owner of the process is allowed to use this
# limit.
#
# Elasticsearch performs poorly when the system is swapping the memory.
#
# ---------------------------------- Network -----------------------------------
#
# By default Elasticsearch is only accessible on localhost. Set a different
# address here to expose this node on the network:
#
#network.host: 192.168.0.1
#
# By default Elasticsearch listens for HTTP traffic on the first free port it
# finds starting at 9200. Set a specific HTTP port here:
#
#http.port: 9200
#
# For more information, consult the network module documentation.
#
# --------------------------------- Discovery ----------------------------------
#
# Pass an initial list of hosts to perform discovery when this node is started:
# The default list of hosts is ["127.0.0.1", "[::1]"]
#
#discovery.seed_hosts: ["host1", "host2"]
#
# Bootstrap the cluster using an initial set of master-eligible nodes:
#
#cluster.initial_master_nodes: ["node-1", "node-2"]
#
# For more information, consult the discovery and cluster formation module documentation.
#
# ---------------------------------- Various -----------------------------------
#
# Require explicit names when deleting indices:
#
#action.destructive_requires_name: true
xpack.security.enabled: true

cluster.name: elasticsearch
node.name: localhost
xpack.security.transport.ssl.enabled: true
xpack.security.transport.ssl.verification_mode: certificate 
xpack.security.transport.ssl.client_authentication: required
xpack.security.transport.ssl.keystore.path: elastic-certificates.p12
xpack.security.transport.ssl.truststore.path: elastic-certificates.p12


xpack.security.http.ssl.enabled: true
xpack.security.http.ssl.keystore.path: http.p12

My kibana.yml file:-

# Kibana is served by a back end server. This setting specifies the port to use.
#server.port: 5601

# Specifies the address to which the Kibana server will bind. IP addresses and host names are both valid values.
# The default is 'localhost', which usually means remote machines will not be able to connect.
# To allow connections from remote users, set this parameter to a non-loopback address.
#server.host: "localhost"

# Enables you to specify a path to mount Kibana at if you are running behind a proxy.
# Use the `server.rewriteBasePath` setting to tell Kibana if it should remove the basePath
# from requests it receives, and to prevent a deprecation warning at startup.
# This setting cannot end in a slash.
#server.basePath: ""

# Specifies whether Kibana should rewrite requests that are prefixed with
# `server.basePath` or require that they are rewritten by your reverse proxy.
# This setting was effectively always `false` before Kibana 6.3 and will
# default to `true` starting in Kibana 7.0.
#server.rewriteBasePath: false

# Specifies the public URL at which Kibana is available for end users. If
# `server.basePath` is configured this URL should end with the same basePath.
#server.publicBaseUrl: ""

# The maximum payload size in bytes for incoming server requests.
#server.maxPayloadBytes: 1048576

# The Kibana server's name.  This is used for display purposes.
#server.name: "your-hostname"

# The URLs of the Elasticsearch instances to use for all your queries.
# elasticsearch.hosts: ["http://localhost:9200"]

# Kibana uses an index in Elasticsearch to store saved searches, visualizations and
# dashboards. Kibana creates a new index if the index doesn't already exist.
#kibana.index: ".kibana"

# The default application to load.
#kibana.defaultAppId: "home"

# If your Elasticsearch is protected with basic authentication, these settings provide
# the username and password that the Kibana server uses to perform maintenance on the Kibana
# index at startup. Your Kibana users still need to authenticate with Elasticsearch, which
# is proxied through the Kibana server.
elasticsearch.username: "elastic"
elasticsearch.password: "wCe1EQE4EkVRGr6Q7LBI"

# Enables SSL and paths to the PEM-format SSL certificate and SSL key files, respectively.
# These settings enable SSL for outgoing requests from the Kibana server to the browser.
#server.ssl.enabled: false
#server.ssl.certificate: /path/to/your/server.crt
#server.ssl.key: /path/to/your/server.key

# Optional settings that provide the paths to the PEM-format SSL certificate and key files.
# These files are used to verify the identity of Kibana to Elasticsearch and are required when
# xpack.security.http.ssl.client_authentication in Elasticsearch is set to required.
#elasticsearch.ssl.certificate: /path/to/your/client.crt
#elasticsearch.ssl.key: /path/to/your/client.key

# Optional setting that enables you to specify a path to the PEM file for the certificate
# authority for your Elasticsearch instance.
#elasticsearch.ssl.certificateAuthorities: [ "/path/to/your/CA.pem" ]

# To disregard the validity of SSL certificates, change this setting's value to 'none'.
#elasticsearch.ssl.verificationMode: full

# Time in milliseconds to wait for Elasticsearch to respond to pings. Defaults to the value of
# the elasticsearch.requestTimeout setting.
#elasticsearch.pingTimeout: 1500

# Time in milliseconds to wait for responses from the back end or Elasticsearch. This value
# must be a positive integer.
#elasticsearch.requestTimeout: 30000

# List of Kibana client-side headers to send to Elasticsearch. To send *no* client-side
# headers, set this value to [] (an empty list).
#elasticsearch.requestHeadersWhitelist: [ authorization ]

# Header names and values that are sent to Elasticsearch. Any custom headers cannot be overwritten
# by client-side headers, regardless of the elasticsearch.requestHeadersWhitelist configuration.
#elasticsearch.customHeaders: {}

# Time in milliseconds for Elasticsearch to wait for responses from shards. Set to 0 to disable.
#elasticsearch.shardTimeout: 30000

# Logs queries sent to Elasticsearch. Requires logging.verbose set to true.
#elasticsearch.logQueries: false

# Specifies the path where Kibana creates the process ID file.
#pid.file: /run/kibana/kibana.pid

# Enables you to specify a file where Kibana stores log output.
#logging.dest: stdout

# Set the value of this setting to true to suppress all logging output.
#logging.silent: false

# Set the value of this setting to true to suppress all logging output other than error messages.
#logging.quiet: false

# Set the value of this setting to true to log all events, including system usage information
# and all requests.
#logging.verbose: false

# Set the interval in milliseconds to sample system and process performance
# metrics. Minimum is 100ms. Defaults to 5000.
#ops.interval: 5000

# Specifies locale to be used for all localizable strings, dates and number formats.
# Supported languages are the following: English - en , by default , Chinese - zh-CN .
#i18n.locale: "en"
elasticsearch.ssl.certificateAuthorities: E:\kibana\config\elasticsearch-ca.pem
elasticsearch.hosts: https://localhost:9200

can you help me to solve this error?

Hi,

could you please try putting your elasticsearch.ssl.certificateAuthorities value in single quotes (to prevent the backslashes in your path from being interpreted as escape sequences, i.e.:

elasticsearch.ssl.certificateAuthorities: 'E:\kibana\config\elasticsearch-ca.pem'

Cheers,
Tim

hi @timroes ,

Thanks for your response.
I tried That .But I got same error.

[error][elasticsearch] Request error, retrying
GET https://localhost:9200/_xpack?accept_enterprise=true => self signed certificate in certificate chain
log [13:37:02.511] [warning][elasticsearch] Unable to revive connection: https://localhost:9200/
log [13:37:02.512] [warning][elasticsearch] No living connections

and i got new WARN in elasticsearch log

[localhost] http client did not trust this server's certificate, closing connection Netty4HttpChannel

Hi,

this looks like now the config is correct, but it seems there has been some issue during certificate generation that makes that certificate untrustworthy still. Either those certifiacates and the authority are a missmatch, or maybe the certificate is not valid for the correct URL. When you followed the documentation: Set up basic security for the Elastic Stack plus secured HTTPS traffic | Elasticsearch Guide [7.13] | Elastic in step h did you maybe not enter localhost as a URL for your certificate?

I suspect the error is related to some missmatch there, but I think the best chance for you is to analyze those certificates and their information (Sorry I am not very well versed how to do that on Windows properly), and check for a missmatch.

Cheers,
Tim

@timroes thanks man.

I will regenerate certificates.