Getting error while enabling SSL in Kibana


(R01K) #1

Hi Team,

I am getting error while configuring SSL in kibana.

Steps that i have tried.

  1. we are using Keytool to generate .key and .crt and public key we are getting from MS PKI.
  2. after including .key and .cert into the kibana.yml file

SSL for outgoing requests from the Kibana Server (PEM formatted)

ssl_key_file: /elkt/ssl/server.key
ssl_cert_file: /elkt/ssl/server.crt

we are getting below error.
crypto.js:135
if (options.cert) c.context.setCert(options.cert);
^
Error: error:0906D06C:PEM routines:PEM_read_bio:no start line
at Object.exports.createCredentials (crypto.js:135:31)

Kindly help me to fix this issue.
Also let me know if you have any steps to configure the SSL in Kibana.

Note: already referred below link but it didnt help to fix the issue.
https://www.elastic.co/guide/en/kibana/current/production.html#enabling-ssl

Thanks,
Rohan


(Rashid Khan) #2

Can you try generating certs with openssl? If i had to guess the certs are in the wrong format.


(R01K) #3

Thanks Rashid,

Could you please provide the steps or any link for enabling SSL for kibana? as we tried generating .cert and .key using openssl but it showing "untrusted certifcate" error on browser.

Any help on this would be really appriciated.

Thanks,
Rohan


(Tanya Bragin) #4

All Shield+Kibana instructions should be here:
https://www.elastic.co/guide/en/shield/current/kibana.html

Also, Kibana server settings around SSL are covered here:
https://www.elastic.co/guide/en/kibana/current/kibana-server-properties.html


(system) #5