Getting error while installing ElasticSeacrh on Win 10


(Prithwish) #1

I am new to this and keep on getting below error after hitting .\elasticsearch.bat

[2018-05-16T15:47:34,733][INFO ][o.e.p.PluginsService ] [tHukO3-] loaded module [aggs-matrix-stats]
[2018-05-16T15:47:34,733][INFO ][o.e.p.PluginsService ] [tHukO3-] loaded module [analysis-common]
[2018-05-16T15:47:34,733][INFO ][o.e.p.PluginsService ] [tHukO3-] loaded module [ingest-common]
[2018-05-16T15:47:34,733][INFO ][o.e.p.PluginsService ] [tHukO3-] loaded module [lang-expression]
[2018-05-16T15:47:34,733][INFO ][o.e.p.PluginsService ] [tHukO3-] loaded module [lang-mustache]
[2018-05-16T15:47:34,733][INFO ][o.e.p.PluginsService ] [tHukO3-] loaded module [lang-painless]
[2018-05-16T15:47:34,733][INFO ][o.e.p.PluginsService ] [tHukO3-] loaded module [mapper-extras]
[2018-05-16T15:47:34,733][INFO ][o.e.p.PluginsService ] [tHukO3-] loaded module [parent-join]
[2018-05-16T15:47:34,733][INFO ][o.e.p.PluginsService ] [tHukO3-] loaded module [percolator]
[2018-05-16T15:47:34,733][INFO ][o.e.p.PluginsService ] [tHukO3-] loaded module [rank-eval]
[2018-05-16T15:47:34,733][INFO ][o.e.p.PluginsService ] [tHukO3-] loaded module [reindex]
[2018-05-16T15:47:34,733][INFO ][o.e.p.PluginsService ] [tHukO3-] loaded module [repository-url]
[2018-05-16T15:47:34,733][INFO ][o.e.p.PluginsService ] [tHukO3-] loaded module [transport-netty4]
[2018-05-16T15:47:34,733][INFO ][o.e.p.PluginsService ] [tHukO3-] loaded module [tribe]
[2018-05-16T15:47:34,733][INFO ][o.e.p.PluginsService ] [tHukO3-] no plugins loaded
[2018-05-16T15:47:38,327][INFO ][o.e.d.DiscoveryModule ] [tHukO3-] using discovery type [zen]
[2018-05-16T15:47:39,734][INFO ][o.e.n.Node ] initialized
[2018-05-16T15:47:39,734][INFO ][o.e.n.Node ] [tHukO3-] starting ...
[2018-05-16T15:47:40,546][INFO ][o.e.t.TransportService ] [tHukO3-] publish_address {127.0.0.1:9300}, bound_addresses {127.0.0.1:9300}, {[::1]:9300}
[2018-05-16T15:47:40,562][WARN ][o.e.b.BootstrapChecks ] [tHukO3-] initial heap size [268435456] not equal to maximum heap size [536870912]; this can cause resize pauses and prevents mlockall from locking the entire heap
[2018-05-16T15:47:40,562][WARN ][o.e.b.BootstrapChecks ] [tHukO3-] JVM is using the client VM [Java HotSpot(TM) Client VM] but should be using a server VM for the best performance
[2018-05-16T15:47:43,609][WARN ][o.e.d.z.ZenDiscovery ] [tHukO3-] not enough master nodes discovered during pinging (found [[]], but needed [-1]), pinging again
[2018-05-16T15:47:46,621][WARN ][o.e.d.z.ZenDiscovery ] [tHukO3-] not enough master nodes discovered during pinging (found [[]], but needed [-1]), pinging again
[2018-05-16T15:47:49,637][WARN ][o.e.d.z.ZenDiscovery ] [tHukO3-] not enough master nodes discovered during pinging (found [[]], but needed [-1]), pinging again
[2018-05-16T15:47:52,653][WARN ][o.e.d.z.ZenDiscovery ] [tHukO3-] not enough master nodes discovered during pinging (found [[]], but needed [-1]), pinging again
[2018-05-16T15:47:55,669][WARN ][o.e.d.z.ZenDiscovery ] [tHukO3-] not enough master nodes discovered during pinging (found [[]], but needed [-1]), pinging again
[2018-05-16T15:47:58,685][WARN ][o.e.d.z.ZenDiscovery ] [tHukO3-] not enough master nodes discovered during pinging (found [[]], but needed [-1]), pinging again
[2018-05-16T15:48:01,701][WARN ][o.e.d.z.ZenDiscovery ] [tHukO3-] not enough master nodes discovered during pinging (found [[]], but needed [-1]), pinging again
[2018-05-16T15:48:10,609][WARN ][o.e.n.Node ] [tHukO3-] timed out while waiting for initial discovery state - timeout: 30s
[2018-05-16T15:49:00,193][INFO ][o.e.h.n.Netty4HttpServerTransport] [tHukO3-] publish_address {127.0.0.1:9200}, bound_addresses {127.0.0.1:9200}, {[::1]:9200}
[2018-05-16T15:49:00,193][INFO ][o.e.n.Node ] [tHukO3-] started
[2018-05-16T15:49:03,162][WARN ][o.e.d.z.ZenDiscovery ] [tHukO3-] not enough master nodes discovered during pinging (found [[]], but needed [-1]), pinging again
[2018-05-16T15:49:06,178][WARN ][o.e.d.z.ZenDiscovery ] [tHukO3-] not enough master nodes discovered during pinging (found [[]], but needed [-1]), pinging again
[2018-05-16T15:49:09,194][WARN ][o.e.d.z.ZenDiscovery ] [tHukO3-] not enough master nodes discovered during pinging (found [[]], but needed [-1]), pinging again

My YML file is

node.master: false
node.data: false
node.ingest: false

cluster.name: "my_cluster"

network.host: localhost
http.port: 9200

action.auto_create_index: .security,.monitoring*,.watches,.triggered_watches,.watcher-history*


(David Pilato) #2

Why did you set:

node.master: false
node.data: false
node.ingest: false

?


(Prithwish) #3

Hi @dadoonet I am not sure about the correct configurations, i just copied it from some other file.
Can you kindly recommend the correct yml file configuration?


(David Pilato) #4

In short: don't touch settings you don't understand.
Here just remove those lines.


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.