Getting hit by oom-killer, recommended settings?


(Jeremy Jongsma-2) #1

I'm running an ES cluster on AWS m1.large instances (7.5 GB RAM) using
elasticsearch-servicewrapper, and am periodically getting hit by the kernel
OOM killer.

In my configuration I have:

index.store.type: memory
cache.memory.direct: true

My JVM memory settings are:

ES_HEAP_SIZE=1024
ES_DIRECT_SIZE=5120m

I am currently running a 5-node cluster with 5 shards and 1 replica. The
total index size is 3.6GB (2.7m documents). I don't ever see any java.lang.OutOfMemoryError:
Direct buffer memory messages I've seen others report, which would seem to
indicate to me that Java is still within its expected memory limits, but
the kernel disagrees.

Do my settings sound reasonable for the machine size I am running on? It
seems to me like it would be, but instances keep getting killed. Any
direction would be appreciated.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Jörg Prante) #2

Lower ES_DIRECT_SIZE and monitor if the kernel OOM killer still gets you.

Jörg

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #3