Gettting error migrating data stream

Hello,
I'm in the process of migrating ELK (both servers on same version 7.17). I'm trying to restore an index wich has the ilm-history datastream. The index is restored but I'm getting this error in log :
java.lang.IllegalArgumentException: setting [index.lifecycle.rollover_alias] for index [.ds-ilm-history-5-2024.01.23-000040] is empty or not defined

I'm guessing because it is not associated to the ilm-history datastream. So I'm trying to reindex to the data stream using :

`POST /_reindex
{  
  "source": {    "index": ".ds-ilm-history-5-2024.01.30-000040"  }, 
  "dest": {    "index": "ilm-history-5" }  
}

But I get the following error : "only write ops with an op_type of create are allowed in data streams"
It seemed to me that this request worked on a previous migration.
So I have tried to reindex to an existing datastream in the new server but it says that I have to target corresponding data stream instead :
"reason" : "index request with op_type=index and no if_primary_term and if_seq_no set targeting backing indices is disallowed, target corresponding data stream [ilm-history-5] instead"

I am all confused now, any help would be greatly appreciated.