Guice creation errors


(jagdish) #1

Hi All,
As per requiements i have to send the data from elasticsearch to cassandra but when everything goes right i.e tables creations,integrations with river plugin,but the issue is (my versions are elasticsearch-1.4.5 and cassandra-3.9) as follows:
[hduser@example bin]$ sudo ./elasticsearch
[sudo] password for hduser:
[2016-11-25 16:40:59,333][INFO ][node ] [Doctor Minerva] version[1.4.5], pid[26203], build[2aaf797/2015-04-27T08:06:06Z]
[2016-11-25 16:40:59,334][INFO ][node ] [Doctor Minerva] initializing ...
[2016-11-25 16:40:59,540][INFO ][plugins ] [Doctor Minerva] loaded [mapper-attachments, cassandra-river], sites [head]
[2016-11-25 16:41:01,701][INFO ][node ] [Doctor Minerva] initialized
[2016-11-25 16:41:01,702][INFO ][node ] [Doctor Minerva] starting ...
[2016-11-25 16:41:01,811][INFO ][transport ] [Doctor Minerva] bound_address {inet[/0.0.0.0:9300]}, publish_address {inet[/192.168.0.110:9300]}
[2016-11-25 16:41:01,844][INFO ][discovery ] [Doctor Minerva] elasticsearch/cEkT6xryRqGq2-0YEvJoYw
[2016-11-25 16:41:05,610][INFO ][cluster.service ] [Doctor Minerva] new_master [Doctor Minerva][cEkT6xryRqGq2-0YEvJoYw][example][inet[/192.168.0.110:9300]], reason: zen-disco-join (elected_as_master)
[2016-11-25 16:41:05,631][INFO ][http ] [Doctor Minerva] bound_address {inet[/0.0.0.0:9200]}, publish_address {inet[/192.168.0.110:9200]}
[2016-11-25 16:41:05,631][INFO ][node ] [Doctor Minerva] started
[2016-11-25 16:41:06,118][INFO ][gateway ] [Doctor Minerva] recovered [3] indices into cluster_state
[2016-11-25 16:41:07,127][WARN ][river ] [Doctor Minerva] failed to create river [cassandra][weatherdata]
org.elasticsearch.common.inject.CreationException: Guice creation errors:

  1. Error injecting constructor, com.datastax.driver.core.exceptions.NoHostAvailableException: All host(s) tried for query failed (tried: localhost/127.0.0.1 (null))
    at com.blu.es.cassandra.CassandraRiver.(Unknown Source)
    while locating com.blu.es.cassandra.CassandraRiver
    while locating org.elasticsearch.river.River

1 error
at org.elasticsearch.common.inject.internal.Errors.throwCreationExceptionIfErrorsExist(Errors.java:344)
at org.elasticsearch.common.inject.InjectorBuilder.injectDynamically(InjectorBuilder.java:178)
at org.elasticsearch.common.inject.InjectorBuilder.build(InjectorBuilder.java:110)
at org.elasticsearch.common.inject.InjectorImpl.createChildInjector(InjectorImpl.java:131)
at org.elasticsearch.common.inject.ModulesBuilder.createChildInjector(ModulesBuilder.java:69)
at org.elasticsearch.river.RiversService.createRiver(RiversService.java:140)
at org.elasticsearch.river.RiversService$ApplyRivers$2.onResponse(RiversService.java:275)
at org.elasticsearch.river.RiversService$ApplyRivers$2.onResponse(RiversService.java:269)
at org.elasticsearch.action.support.TransportAction$ThreadedActionListener$1.run(TransportAction.java:113)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
at java.lang.Thread.run(Thread.java:745)
Caused by: com.datastax.driver.core.exceptions.NoHostAvailableException: All host(s) tried for query failed (tried: localhost/127.0.0.1 (null))
at com.datastax.driver.core.ControlConnection.reconnectInternal(ControlConnection.java:195)

Coulld you please suggest me on this

Thanks ,
Jagan


(David Pilato) #2

Don't use rivers. They are removed now.


(jagdish) #3

Hi David,
Thanks for the reply.
Could you please suggest how to integrate ES with Cassandra.
Could i use 'Jdbc importer'?

Regards,
jagan


(David Pilato) #4

I have no idea. But I'm sure someone asked for this already in this forum. Did you search for it?


(Jörg Prante) #5

Yes. Use a Cassandra JDBC driver. Please note that ES 1.4.5 is not supported by JDBC importer, you'd have to upgrade to at least ES 1.6

BTW the error you got has nothing to do with Guice or with rivers. It is just that Cassandra is not reachable.


(Jörg Prante) #6

This will not work with JDBC importer. It's the other way round.


(jagdish) #7

Hi Jorg,
Thanks for the info....
could you Please suggest me the otherway?

Regards,
Jagan


(David Pilato) #8

If you want to import elasticsearch data into Cassandra, then it's a Cassandra question. Not an elasticsearch question.

Can you tell more about what you are exactly trying to do by combining the 2 systems here?


(jagdish) #9

my question was about taking(getting )data from Cassandra to Elasticsearch there by i need to do reports in kibana.This is my requirment.


(David Pilato) #10

So follow what @jprante said.


(system) #11

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.