[Hadoop][pig] How to set the document id in ESStorage?


(Arokia Daniel Arokiadoss) #1

Hi,

I've been doing some Aggregation functional using the ES STORE and
Hadoop-PIG functionality . I want to store the aggregated data in
Elasticsearch through PIG. While storing the data , elasticsearch generates
document id automatically. Is there a way to set document id manually in
run time?

A simple working example would really help me out.

This page not working for me :
http://elasticsearch-users.115913.n3.nabble.com/Hadoop-pig-How-to-set-the-document-id-td4045260.html

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/acb4687e-fea4-476f-879f-0cfbd6ea1ab9%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Costin Leau) #2

You can through the 'es.mapping.id' parameter; see [1]

Cheers,

[1] http://www.elasticsearch.org/guide/en/elasticsearch/hadoop/current/configuration.html#_mapping

On 9/2/14 11:24 AM, Arokia Daniel Arokiadoss wrote:

Hi,

I've been doing some Aggregation functional using the ES STORE and Hadoop-PIG functionality . I want to store the
aggregated data in Elasticsearch through PIG. While storing the data , elasticsearch generates document id
automatically. Is there a way to set document id manually in run time?

A simple working example would really help me out.

This page not working for me :
http://elasticsearch-users.115913.n3.nabble.com/Hadoop-pig-How-to-set-the-document-id-td4045260.html

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to
elasticsearch+unsubscribe@googlegroups.com mailto:elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/acb4687e-fea4-476f-879f-0cfbd6ea1ab9%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/acb4687e-fea4-476f-879f-0cfbd6ea1ab9%40googlegroups.com?utm_medium=email&utm_source=footer.
For more options, visit https://groups.google.com/d/optout.

--
Costin

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/5405A744.4070509%40gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Arokia Daniel Arokiadoss) #3

Yep.Working good for me :slight_smile: Thanks.

On Tuesday, September 2, 2014 4:47:41 PM UTC+5:30, Costin Leau wrote:

You can through the 'es.mapping.id' parameter; see [1]

Cheers,

[1]
http://www.elasticsearch.org/guide/en/elasticsearch/hadoop/current/configuration.html#_mapping

On 9/2/14 11:24 AM, Arokia Daniel Arokiadoss wrote:

Hi,

I've been doing some Aggregation functional using the ES STORE and
Hadoop-PIG functionality . I want to store the
aggregated data in Elasticsearch through PIG. While storing the data ,
elasticsearch generates document id
automatically. Is there a way to set document id manually in run time?

A simple working example would really help me out.

This page not working for me :

http://elasticsearch-users.115913.n3.nabble.com/Hadoop-pig-How-to-set-the-document-id-td4045260.html

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to
elasticsearc...@googlegroups.com <javascript:> <mailto:
elasticsearch+unsubscribe@googlegroups.com <javascript:>>.
To view this discussion on the web visit

https://groups.google.com/d/msgid/elasticsearch/acb4687e-fea4-476f-879f-0cfbd6ea1ab9%40googlegroups.com

<
https://groups.google.com/d/msgid/elasticsearch/acb4687e-fea4-476f-879f-0cfbd6ea1ab9%40googlegroups.com?utm_medium=email&utm_source=footer>.

For more options, visit https://groups.google.com/d/optout.

--
Costin

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/a7dbc173-5e05-4741-b359-ab9921c38987%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(system) #4