Has_child queries fail if queryName is set


(Riyaz) #1

Hi,

I am using elasticsearch v0.90.5 and trying to set QueryName (_name) for a
has_child query as described
here: http://www.elasticsearch.org/guide/en/elasticsearch/reference/0.90/search-request-named-queries-and-filters.html

But the has_child queries are failing if queryName is set. They also fail
if queryName is set on a wrapping query. You can find the curl recreation
here: https://gist.github.com/hmrizin/9645816

What am I missing? Any help appreciated.

Thanks
Riyaz

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/7bc36970-9bcd-4fc1-b3ab-fe16ca07df93%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Martijn Van Groningen) #2

This is a bug and has been fixed. Can you try using the latest 0.90.x
release or maybe upgrade to the latest 1.0.x release?

On 20 March 2014 00:02, Riyaz mohamed.riyaz@gmail.com wrote:

Hi,

I am using elasticsearch v0.90.5 and trying to set QueryName (_name) for a
has_child query as described here:
http://www.elasticsearch.org/guide/en/elasticsearch/reference/0.90/search-request-named-queries-and-filters.html

But the has_child queries are failing if queryName is set. They also fail
if queryName is set on a wrapping query. You can find the curl recreation
here: https://gist.github.com/hmrizin/9645816

What am I missing? Any help appreciated.

Thanks
Riyaz

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/7bc36970-9bcd-4fc1-b3ab-fe16ca07df93%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/7bc36970-9bcd-4fc1-b3ab-fe16ca07df93%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
Met vriendelijke groet,

Martijn van Groningen

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CA%2BA76TzEDDc8snopE_pgv%2BpTfUsm0XEpH2ZncB7K8O%3DkAEnb1A%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Riyaz) #3

Thanks Martijn

Tried in v0.90.12 and it works. Thank You!

On Thursday, March 20, 2014 7:21:57 AM UTC-4, Martijn v Groningen wrote:

This is a bug and has been fixed. Can you try using the latest 0.90.x
release or maybe upgrade to the latest 1.0.x release?

On 20 March 2014 00:02, Riyaz <mohame...@gmail.com <javascript:>> wrote:

Hi,

I am using elasticsearch v0.90.5 and trying to set QueryName (_name) for
a has_child query as described here:
http://www.elasticsearch.org/guide/en/elasticsearch/reference/0.90/search-request-named-queries-and-filters.html

But the has_child queries are failing if queryName is set. They also fail
if queryName is set on a wrapping query. You can find the curl recreation
here: https://gist.github.com/hmrizin/9645816

What am I missing? Any help appreciated.

Thanks
Riyaz

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/7bc36970-9bcd-4fc1-b3ab-fe16ca07df93%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/7bc36970-9bcd-4fc1-b3ab-fe16ca07df93%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
Met vriendelijke groet,

Martijn van Groningen

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/fe889a90-7afe-4574-ab2d-dc1b89dd601d%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(system) #4