Has_parent 0.90.1 grandchild issue

Hi folks

I believe there is an issue with grandchild type mapping in version 0.90.1.
By 'grandchild' i am referring to mappings which are related to each other
in the form of 'GrandParent' > 'Parent' > 'Child'. Put simply in 0.90.1 if
the 'Child' mapping is defined any query against the 'Parent' which uses a
has_parent query will fail to return any results. In version 0.90.0 the
query returns a result as expected.

Gist to reproduce: https://gist.github.com/jbong/5705764

Note that adding a document to the 'Child' type is not necessary to
reproduce the problem, simply adding it as a mapping seems to prevent a
query against the 'Parent', which includes has_parent, from returning any
results.

Any help much appreciated

jb

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Hi jb,

This is a bug. I'll open an issue shortly for this. Thanks for bringing
this up!

Martijn

On 4 June 2013 15:27, jbong jeremy@egrove.co.uk wrote:

Hi folks

I believe there is an issue with grandchild type mapping in version
0.90.1. By 'grandchild' i am referring to mappings which are related to
each other in the form of 'GrandParent' > 'Parent' > 'Child'. Put simply in
0.90.1 if the 'Child' mapping is defined any query against the 'Parent'
which uses a has_parent query will fail to return any results. In version
0.90.0 the query returns a result as expected.

Gist to reproduce: https://gist.github.com/jbong/5705764

Note that adding a document to the 'Child' type is not necessary to
reproduce the problem, simply adding it as a mapping seems to prevent a
query against the 'Parent', which includes has_parent, from returning any
results.

Any help much appreciated

jb

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
Met vriendelijke groet,

Martijn van Groningen

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Btw: I have created the following issue:

On 5 June 2013 20:03, Martijn v Groningen martijn.v.groningen@gmail.comwrote:

Hi jb,

This is a bug. I'll open an issue shortly for this. Thanks for bringing
this up!

Martijn

On 4 June 2013 15:27, jbong jeremy@egrove.co.uk wrote:

Hi folks

I believe there is an issue with grandchild type mapping in version
0.90.1. By 'grandchild' i am referring to mappings which are related to
each other in the form of 'GrandParent' > 'Parent' > 'Child'. Put simply in
0.90.1 if the 'Child' mapping is defined any query against the 'Parent'
which uses a has_parent query will fail to return any results. In version
0.90.0 the query returns a result as expected.

Gist to reproduce: https://gist.github.com/jbong/5705764

Note that adding a document to the 'Child' type is not necessary to
reproduce the problem, simply adding it as a mapping seems to prevent a
query against the 'Parent', which includes has_parent, from returning any
results.

Any help much appreciated

jb

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
Met vriendelijke groet,

Martijn van Groningen

--
Met vriendelijke groet,

Martijn van Groningen

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Awesome..thank you for the quick reply Martijn :wink:

On Wednesday, June 5, 2013 9:09:25 PM UTC+1, Martijn v Groningen wrote:

Btw: I have created the following issue:
https://github.com/elasticsearch/elasticsearch/issues/3139

On 5 June 2013 20:03, Martijn v Groningen <martijn.v...@gmail.com<javascript:>

wrote:

Hi jb,

This is a bug. I'll open an issue shortly for this. Thanks for bringing
this up!

Martijn

On 4 June 2013 15:27, jbong <jer...@egrove.co.uk <javascript:>> wrote:

Hi folks

I believe there is an issue with grandchild type mapping in version
0.90.1. By 'grandchild' i am referring to mappings which are related to
each other in the form of 'GrandParent' > 'Parent' > 'Child'. Put simply in
0.90.1 if the 'Child' mapping is defined any query against the 'Parent'
which uses a has_parent query will fail to return any results. In version
0.90.0 the query returns a result as expected.

Gist to reproduce: https://gist.github.com/jbong/5705764

Note that adding a document to the 'Child' type is not necessary to
reproduce the problem, simply adding it as a mapping seems to prevent a
query against the 'Parent', which includes has_parent, from returning any
results.

Any help much appreciated

jb

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com <javascript:>.
For more options, visit https://groups.google.com/groups/opt_out.

--
Met vriendelijke groet,

Martijn van Groningen

--
Met vriendelijke groet,

Martijn van Groningen

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.