Have a problem to map lat long field

Hi, I have a problem with mapping latlong in elastic search

Here is my input data to elastic search server

{
"member_id": "8",
"keywords": [
"Sample 2",
"Sample 3",
"s",
"sample"
],
"long_descriptions": "Des",
"general_desc": "Sample",
"service_location": 1,
"categories": [
"Entertainment Entertainment Entertainment Entertai",
"DJ’s",
"Personal Driver",
"Transportation Services"
],

  • "pin": {*
  •    "location": {*
    
  •        "lat": 33.8101772,*
    
  •        "lon": -118.3520389*
    
  •    }*
    
  • },*
    "status": 1,
    "state": true
    }

and when I check the mapping it shows like

"member_id": {
"type": "string"
},
"pin": {

  •                    "properties": {*
    
  •                        "location": {*
    
  •                            "properties": {*
    
  •                                "lat": {*
    
  •                                    "type": "double"*
    
  •                                },*
    
  •                                "lon": {*
    
  •                                    "type": "double"*
    
  •                                }*
    
  •                            }*
    
  •                        }*
    
  •                    }*
                  },
    

I am currently using elasticsearch v1.0.1, is this something related to the
installation of elasticsearch?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/084dd688-b7c8-4d31-a0bc-1ad4ecdc0be3%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

There is no autodetection of geo_point.
So you need to provide first a mapping before sending the first document.

David

Le 16 déc. 2014 à 07:47, Anoop P R anoopkumaranalloor@gmail.com a écrit :

Hi, I have a problem with mapping latlong in elastic search

Here is my input data to elastic search server

{
"member_id": "8",
"keywords": [
"Sample 2",
"Sample 3",
"s",
"sample"
],
"long_descriptions": "Des",
"general_desc": "Sample",
"service_location": 1,
"categories": [
"Entertainment Entertainment Entertainment Entertai",
"DJ’s",
"Personal Driver",
"Transportation Services"
],
"pin": {
"location": {
"lat": 33.8101772,
"lon": -118.3520389
}
},
"status": 1,
"state": true
}

and when I check the mapping it shows like

"member_id": {
"type": "string"
},
"pin": {
"properties": {
"location": {
"properties": {
"lat": {
"type": "double"
},
"lon": {
"type": "double"
}
}
}
}
},

I am currently using elasticsearch v1.0.1, is this something related to the installation of elasticsearch?

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/084dd688-b7c8-4d31-a0bc-1ad4ecdc0be3%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/AF1B6386-3FA3-40A6-9C99-D0F92B733FD9%40pilato.fr.
For more options, visit https://groups.google.com/d/optout.

Thanks David, Now its works for me.

On Tuesday, December 16, 2014 12:55:45 PM UTC+5:30, David Pilato wrote:

There is no autodetection of geo_point.
So you need to provide first a mapping before sending the first document.

David

Le 16 déc. 2014 à 07:47, Anoop P R <anoopkuma...@gmail.com <javascript:>>
a écrit :

Hi, I have a problem with mapping latlong in elastic search

Here is my input data to elastic search server

{
"member_id": "8",
"keywords": [
"Sample 2",
"Sample 3",
"s",
"sample"
],
"long_descriptions": "Des",
"general_desc": "Sample",
"service_location": 1,
"categories": [
"Entertainment Entertainment Entertainment Entertai",
"DJ’s",
"Personal Driver",
"Transportation Services"
],

  • "pin": {*
  •    "location": {*
    
  •        "lat": 33.8101772,*
    
  •        "lon": -118.3520389*
    
  •    }*
    
  • },*
    "status": 1,
    "state": true
    }

and when I check the mapping it shows like

"member_id": {
"type": "string"
},
"pin": {

  •                    "properties": {*
    
  •                        "location": {*
    
  •                            "properties": {*
    
  •                                "lat": {*
    
  •                                    "type": "double"*
    
  •                                },*
    
  •                                "lon": {*
    
  •                                    "type": "double"*
    
  •                                }*
    
  •                            }*
    
  •                        }*
    
  •                    }*
                  },
    

I am currently using elasticsearch v1.0.1, is this something related to
the installation of elasticsearch?

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/084dd688-b7c8-4d31-a0bc-1ad4ecdc0be3%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/084dd688-b7c8-4d31-a0bc-1ad4ecdc0be3%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/2596df36-55a8-494b-be53-abdfc99d9a17%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.