Having trouble running elasticsearch

I am trying to run elasticsearch from my terminal and I'm getting this error:

warning: ignoring JAVA_HOME=/usr/lib/jvm/java-11-openjdk-arm64; using bundled JDK
Dynarec for ARM64, with extension: ASIMD AES CRC32 PMULL ATOMICS PageSize:4096 Cores:2
Params database has 15 entries
Box64 with Dynarec v0.2.1 8d9c6b2d built on Feb 26 2023 21:50:40
Using default BOX64_LD_LIBRARY_PATH: ./:lib/:lib64/:x86_64/:bin64/:libs64/
Using default BOX64_PATH: ./:bin/
Counted 49 Env var
Looking for /home/parallels/elasticsearch/jdk/bin/java
Rename process to "java"
Using native(wrapped) libz.so.1
Using emulated /home/parallels/elasticsearch/jdk/bin/../lib/libjli.so
Using native(wrapped) libpthread.so.0
Using native(wrapped) libdl.so.2
Using native(wrapped) libc.so.6
Using native(wrapped) ld-linux-x86-64.so.2
Using native(wrapped) libutil.so.1
Using native(wrapped) librt.so.1
Using emulated /home/parallels/elasticsearch/jdk/lib/server/libjvm.so
Using native(wrapped) libm.so.6
Warning: Weak Symbol collector_func_load not found, cannot apply R_X86_64_JUMP_SLOT @0xffff92447a70 (0x282076)
Warning, resizing of TLS occured! size: 0->65536 / n_elfs: 1->1
Using emulated /home/parallels/elasticsearch/jdk/lib/libjimage.so
Using emulated /home/parallels/elasticsearch/jdk/lib/libjava.so
Using emulated /home/parallels/elasticsearch/jdk/lib/libjsvml.so
Using emulated /home/parallels/elasticsearch/jdk/lib/libnio.so
Using emulated /home/parallels/elasticsearch/jdk/lib/libnet.so
Using emulated /home/parallels/elasticsearch/jdk/lib/libzip.so
Error: Could not find or load main class org.elasticsearch.launcher.CliToolLauncher
Caused by: java.lang.ClassNotFoundException: org.elasticsearch.launcher.CliToolLauncher

I am running an ARM64 version of Ubuntu on an m2 mac, at first i thought that was the problem but it seems it's just some java class missing and I'm not sure what to do.

Hi @bawac Welcome to the community.

Couple more items...

Exactly what version of elasticsearch did you download? Kinda looks like perhaps you are trying to run the x86 not the aarch64 which are the ARM builds


Exactly how did you install?

Exactly what command did you run?

Hey, that was exactly the problem. I downloaded the wrong thing and tried to run x86 instead of the arm version. After I downloaded the correct version, everything worked. Sorry for the poor question.

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.