Headers are not being sent


I have a http type heartbeat monitor with headers. However, it seems that the headers are note being sent. Below is the conf. from the yml file. What am i doing wrong?

  • type: http # Analytics-NonProd monitor type http.

    Monitor name used for job name and document type

    name: Analytics-NonProd
    id: analyticsnonprd

    Enable/Disable monitor

    enabled: true

    Configure task schedule

    schedule: '@every 5s' # every 5 seconds from start of beat

    Configure URLs to ping


    Required TLS protocols

    supported_protocols: ["TLSv1.0", "TLSv1.1", "TLSv1.2"]

    Request settings:

    method: GET
    'client_id': 'fd7d448bb3344016be6670ecd36f09d6'
    'client_secret': 'e14df1C299074A7892dd60bB00066A27'
    status: 200

See the HTTP check documentation here. You're setting headers, which is not an option, when you'll want to set check.response.headers.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.