Health Check URL

I have Elasticsearch installed and operating fine, but none of the URL functions are working for me. For example, I enter http://:9200/_
cat/health?v into a web browser (with the applicable IP address of course), but it never works. I've tried some other parameters such as /indices?v still with no luck. Is this a function I need to enable in the elasticsearch.yml?


No. Nothing has to be set in elasticsearch.yml file unless your elasticsearch node is not on the same machine.

If it's the case, you need to fix the setting as by default elasticsearch only listen on localhost.

Thanks for the reply. They are both on the same machine as it's a quick test environment. Through all this though I never actually tried "localhost". That worked for me.

Thanks a million!

Yeah the logs tell you on which interface the service is bound. This is the address to use.

Yeah I'm still learning the ins and outs of this animal. Got a long way to go. lol.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.