Heartbeat bug with fix in 7.x, if no backport... doc fix in 6.x?

(Martin R.) #1

Hi,

I lost some time investigating why Heartbeat 6.6.2 (lastest stable) was not respecting the "Host" http header I was configuring in an HTTP monitor.

I was using exactly what the doc was saying, etc.
Turns out when I understood the issue was specific to a specific header.. "Host" and not to all http headers. I looked for a known or unknown bug and found:

Question is:
If this fix is not scheduled to be backported to older heartbeat, I would recommend a documentation fix for older version that support the http header settings but ignore the specific "Host" http header.

What do you think, poor me (and others) trying to only override the Host header and not knowing about this bug in heartbeat < 7.

I am now using heartbeat 7.0.0-beta1 because I absolutely needed this fix for what I'm doing.
So I was very happy to found that by moving to a pre-release I'm unblocked for this, but wanted to save the headache to others through a doc update.

It would go here I guess:
https://www.elastic.co/guide/en/beats/heartbeat/current/configuration-heartbeat-options.html#monitor-http-check

With the check.request.headers doc.

Martin
Gold license customer
Running self-managed 5.5.2 cluster on AWS ECS.

Heartbeat http monitor is not sending headers
(Andrew Cholakian) #2

The fix targeted 6.7 https://github.com/elastic/beats/pull/9728 . 6.7 should be released relatively soon and should include this patch except in the very unlikely event that something goes terribly wrong.

(Martin R.) #3

Sorry for missing this and wasting your time...

Martin

(Andrew Cholakian) #4

No worries at all! It was confusing given the age of the patch.

(system) closed #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.