Heartbeat not creating index

Hello I have the issue, that Heartbeat is not creating an index:

I get the Error "No data has been received from Heartbeat yet"

We use the Version 7.9.1

heartbeat test config
Config OK

heartbeat test output
elasticsearch: https://elastic:9200...
  parse url... OK
  connection...
    parse host... OK
    dns lookup... OK
    addresses: 10.100.10.127
    dial up... OK
  TLS...
    security: server's certificate chain verification is enabled
    handshake... OK
    TLS version: TLSv1.3
    dial up... OK
  talk to server... OK
  version: 7.9.1


heartbeat -e
2021-03-31T10:49:02.757+0200    INFO    instance/beat.go:645    Home path: [C:\Program Files (x86)\heartbeat-7.10.1-windows-x86_64\heartbeat-7.10.1-windows-x86_64] Config path: [C:\Program Files (x86)\heartbeat-7.10.1-windows-x86_64\heartbeat-7.10.1-windows-x86_64] Data path: [C:\Program Files (x86)\heartbeat-7.10.1-windows-x86_64\heartbeat-7.10.1-windows-x86_64\data] Logs path: [C:\Program Files (x86)\heartbeat-7.10.1-windows-x86_64\heartbeat-7.10.1-windows-x86_64\logs]
2021-03-31T10:49:02.757+0200    INFO    instance/beat.go:653    Beat ID: 18911586-aceb-4824-9b59-5efeda35c664
2021-03-31T10:49:02.766+0200    INFO    [beat]  instance/beat.go:981    Beat info       {"system_info": {"beat": {"path": {"config": "C:\\Program Files (x86)\\heartbeat-7.10.1-windows-x86_64\\heartbeat-7.10.1-windows-x86_64", "data": "C:\\Program Files (x86)\\heartbeat-7.10.1-windows-x86_64\\heartbeat-7.10.1-windows-x86_64\\data", "home": "C:\\Program Files (x86)\\heartbeat-7.10.1-windows-x86_64\\heartbeat-7.10.1-windows-x86_64", "logs": "C:\\Program Files (x86)\\heartbeat-7.10.1-windows-x86_64\\heartbeat-7.10.1-windows-x86_64\\logs"}, "type": "heartbeat", "uuid": "18911586-aceb-4824-9b59-5efeda35c664"}}}
2021-03-31T10:49:02.766+0200    INFO    [beat]  instance/beat.go:990    Build info      {"system_info": {"build": {"commit": "1da173a9e716715a7a54bb3ff4db05b5c24fc8ce", "libbeat": "7.10.1", "time": "2020-12-04T23:33:17.000Z", "version": "7.10.1"}}}
2021-03-31T10:49:02.766+0200    INFO    [beat]  instance/beat.go:993    Go runtime info {"system_info": {"go": {"os":"windows","arch":"amd64","max_procs":2,"version":"go1.14.12"}}}
2021-03-31T10:49:02.772+0200    INFO    [beat]  instance/beat.go:997    Host info       {"system_info": {"host": {"architecture":"x86_64","boot_time":"2020-11-10T07:09:24.98+01:00","name":"VMLWI-ROCP01","ip":["fe80::d4ef:8454:8ffb:882c/64","10.100.11.151/24","::1/128","127.0.0.1/8","fe80::5efe:a64:b97/128"],"kernel_version":"10.0.14393.3321 (rs1_release.191016-1811)","mac":["00:50:56:b3:59:93","00:00:00:00:00:00:00:e0"],"os":{"family":"windows","platform":"windows","name":"Windows Server 2016 Datacenter","version":"10.0","major":10,"minor":0,"patch":0,"build":"14393.3326"},"timezone":"CEST","timezone_offset_sec":7200,"id":"3a8c82cf-08cd-4af8-b6bb-7d7f91c5fb96"}}}
2021-03-31T10:49:02.772+0200    INFO    [beat]  instance/beat.go:1026   Process info    {"system_info": {"process": {"cwd": "C:\\Program Files (x86)\\heartbeat-7.10.1-windows-x86_64\\heartbeat-7.10.1-windows-x86_64", "exe": "C:\\Program Files (x86)\\heartbeat-7.10.1-windows-x86_64\\heartbeat-7.10.1-windows-x86_64\\heartbeat.exe", "name": "heartbeat.exe", "pid": 5708, "ppid": 4760, "start_time": "2021-03-31T10:49:02.659+0200"}}}
2021-03-31T10:49:02.773+0200    INFO    instance/beat.go:299    Setup Beat: heartbeat; Version: 7.10.1
2021-03-31T10:49:02.774+0200    INFO    [index-management]      idxmgmt/std.go:184      Set output.elasticsearch.index to 'heartbeat-7.10.1' as ILM is enabled.
2021-03-31T10:49:02.775+0200    INFO    eslegclient/connection.go:99    elasticsearch url: https://elastic:9200
2021-03-31T10:49:02.775+0200    INFO    [publisher]     pipeline/module.go:113  Beat name: VMLWI-ROCP01
2021-03-31T10:49:02.776+0200    INFO    instance/beat.go:455    heartbeat start running.
2021-03-31T10:49:02.777+0200    INFO    [monitoring]    log/log.go:118  Starting metrics logging every 30s
2021-03-31T10:49:02.777+0200    INFO    beater/heartbeat.go:82  heartbeat is running! Hit CTRL-C to stop it.
2021-03-31T10:49:02.780+0200    INFO    monitors/factory.go:108 Client connection with: beat.ClientConfig{PublishMode:0x0, Processing:beat.ProcessingConfig{EventMetadata:common.EventMetadata{Fields:null, FieldsUnderRoot:false, Tags:[]string(nil)}, Meta:null, Fields:null, DynamicFields:(*common.MapStrPointer)(nil), Processor:beat.ProcessorList(nil), KeepNull:false, DisableHost:false, Private:interface {}(nil)}, CloseRef:beat.CloseRef(nil), WaitClose:0, ACKHandler:beat.ACKer(nil), Events:beat.ClientEventer(nil)}
2021-03-31T10:49:02.784+0200    INFO    cfgfile/reload.go:164   Config reloader started
2021-03-31T10:49:02.785+0200    INFO    cfgfile/reload.go:224   Loading of config files completed.
2021-03-31T10:49:03.835+0200    INFO    [publisher_pipeline_output]     pipeline/output.go:143  Connecting to backoff(elasticsearch(https://elastic:9200))
2021-03-31T10:49:03.835+0200    INFO    [publisher]     pipeline/retry.go:219   retryer: send unwait signal to consumer
2021-03-31T10:49:03.838+0200    INFO    [publisher]     pipeline/retry.go:223     done
2021-03-31T10:49:03.847+0200    INFO    [esclientleg]   eslegclient/connection.go:314   Attempting to connect to Elasticsearch version 7.9.1
2021-03-31T10:49:03.851+0200    INFO    [license]       licenser/es_callback.go:51      Elasticsearch license: Gold
2021-03-31T10:49:03.851+0200    INFO    [esclientleg]   eslegclient/connection.go:314   Attempting to connect to Elasticsearch version 7.9.1
2021-03-31T10:49:03.853+0200    INFO    [index-management]      idxmgmt/std.go:261      Auto ILM enable success.
2021-03-31T10:49:03.916+0200    INFO    [index-management]      idxmgmt/std.go:274      ILM policy successfully loaded.
2021-03-31T10:49:03.916+0200    INFO    [index-management]      idxmgmt/std.go:407      Set setup.template.name to '{heartbeat-7.10.1 {now/d}-000001}' as ILM is enabled.
2021-03-31T10:49:03.917+0200    INFO    [index-management]      idxmgmt/std.go:412      Set setup.template.pattern to 'heartbeat-7.10.1-*' as ILM is enabled.
2021-03-31T10:49:03.920+0200    INFO    [index-management]      idxmgmt/std.go:446      Set settings.index.lifecycle.rollover_alias in template to {heartbeat-7.10.1 {now/d}-000001} as ILM is enabled.
2021-03-31T10:49:03.920+0200    INFO    [index-management]      idxmgmt/std.go:450      Set settings.index.lifecycle.name in template to {heartbeat {"policy":{"phases":{"hot":{"actions":{"rollover":{"max_age":"30d","max_size":"50gb"}}}}}}} as ILM is enabled.
2021-03-31T10:49:03.922+0200    INFO    template/load.go:97     Template heartbeat-7.10.1 already exists and will not be overwritten.
2021-03-31T10:49:03.933+0200    INFO    [index-management]      idxmgmt/std.go:298      Loaded index template.
2021-03-31T10:49:03.934+0200    INFO    [index-management]      idxmgmt/std.go:309      Write alias successfully generated.
2021-03-31T10:49:03.936+0200    INFO    [publisher_pipeline_output]     pipeline/output.go:151  Connection to backoff(elasticsearch(https://elastic:9200)) established


This is the config:

heartbeat.config.monitors:
  # Directory + glob pattern to search for configuration files
  path: ${path.config}/monitors.d/*.yml
  reload.enabled: false
  reload.period: 5s

# Configure monitors inline
heartbeat.monitors:
- type: http
  id: orchestrator
  name: Prod Orchestrator
  urls: ["https://orchestrator.ads.lan"]
  schedule: '@every 10s'

setup.kibana:

  host: "https://elastic:5601"
  I tried also:
  hosts: ["https://vmlli-elsp01.ads.lan:5601","https://vmlli-elsp02.ads.lan:5601","https://vmlli-elsp03.ads.lan:5601"]

output.elasticsearch:
  # Array of hosts to connect to.
  hosts: ["https://vmlli-elsp01.ads.lan:9200","https://vmlli-elsp02.ads.lan:9200","https://vmlli-elsp03.ads.lan:9200"]


  protocol: "https"

  username: "elastic"
  password: "XXXXXXX"

The only difference to our Development Environment (where it works flawless) is that on production we use a cluster.

In _cat/indices there is also no Heartbeat* index.

Hi @mralladin, welcome to discuss :slight_smile:

Does heartbeat stop after printing these logs? Is something else logged?

You can try enabling debug logs adding the flag -E logging.level=debug.

Hi @jsoriano thank you very much at first. I was able to fix the issue. I had not enough rights to see this index. After giving like all rights I was able to see the index and it worked. Thanks for the hint with the debug logs I will use it in the future.

1 Like