Heartbeatのインデックス名を任意に指定する方法

heartbeatからElasticsearchに送信したデータを、任意の名前でインデックス登録したいです。
以下の設定をheartbeat.ymlに設定したのですが、デフォルトのheartbeat-7.5.0-2020.02.02-000003のような名前で入ってしまいます。
考えられる原因を教えて頂けないでしょうか

#==================== Elasticsearch template setting ==========================

setup.template.name: "heartbeat-soctest"
setup.template.pattern: "heartbeat-fb-*"

#-------------------------- Elasticsearch output ------------------------------
index: "heartbeat-fb-%{+yyyy.MM.dd}"
setup.ilm.enabled: true
setup.ilm.rollover_alias: "heartbeat-fb"
setup.ilm.policy_name: "heartbeat-soctest"

こんにちわ

こちらで、新規環境で同じように設定し試したところ指定されたIndex名でデータが入っていました。

お見受けしたところ、000003のようなIndexが作成されていることから
古い設定やデータが残っていてその影響がある、といったことはありませんでしょうか?
一度、空のElasticsearch環境にHeartbeatを接続してみる、ということを試してみると良いかもしれません。

使用したheartbeatの変更部分は以下の通りです。

#================================ General =====================================

setup.template.name: "heartbeat-soctest"
setup.template.pattern: "heartbeat-fb-*"

#============================== Setup ILM =====================================

setup.ilm.enabled: auto
setup.ilm.rollover_alias: "heartbeat-fb"
setup.ilm.policy_name: "heartbeat-soctest"

#================================ Outputs =====================================

# Configure what output to use when sending the data collected by the beat.

#-------------------------- Elasticsearch output ------------------------------
output.elasticsearch:
  # Array of hosts to connect to.
  hosts: ["localhost:9200"]
  index: "heartbeat-fb-%{+yyyy.MM.dd}"


何らかの理由があってindex名を変えたい、とのことだと思いますが、1つだけ補足させてください。

heartbeatで入れたデータはUptimeで可視化できるようになっていますが、Index名を変えるとUptimeで見るIndex先も変更してあげる必要があります。

https://www.elastic.co/guide/en/uptime/current/install-heartbeat.html

  • The Uptime UI requires a heartbeat-8* index pattern. If you have configured a different index pattern, you can use index aliases to ensure data is recognized by the UI.

UptimeのIndex指定については、こんな質問が過去にあったようです。

ご回答ありがとうございます。

設定を確認したところ、先頭に空白が入っていたことが原因のようでした。
空白を消して先頭から定義したところ、想定通りの結果となりました

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.