Heatmap hide specific column

Hi,

I'm trying to create a heatmap but I encounter some issues.

This is how it looked at first:


Here, the X axis is not sorted and miss values (going from 1 to 15).

I found I can fix it by adding {"min_doc_count":0} on the advanced tab, so now I get this:


Now I get the full range for the X axis, but I also get a column "0", which is a value that can never happen in our case.

Is there a way to hide this specific column without losing the 1-15 range?
I tried adding 0 in the "exclude value" in advanced tab and excluding the value in filters, but didn't worked.

Thank you

The heatmap visualization does not have the kind of customization options you're asking for. If these are required, then I would suggest that you learn how to use Vega. Vega is capable of fully custom heatmaps.

Hello,

Thanks for your answer. I'll start looking into Vega for the next time I need it.

As a workaround, I used an "ugly-but-working" way by using a filters sub-aggregation on the X-axis, with a filter for each battery (having only 15 possible values)