HELP - 2nd node not joining cluster


(Lowdmt) #1

Hi,

I have a single node elastic, logstash and kibana RedHat device. All is well. Working as expected.

I'm trying to add a 2nd node but having issues connecting the 2nd node to the cluster.

Both nodes are in the same VLAN, they can ping and telnet to each other.

Is there something wrong with my elasticsearch.yml files?

Node1

======================== Elasticsearch Configuration =========================

---------------------------------- Cluster -----------------------------------

cluster.name: Torvalds

------------------------------------ Node ------------------------------------

node.name: node-1 - 84
node.master: true
node.data: true

----------------------------------- Paths ------------------------------------

path.data: /opt/elastic
path.logs: /var/log/elasticsearch

----------------------------------- Memory -----------------------------------

---------------------------------- Network -----------------------------------

network.host: 20.138.120.84
http.port: 9200

--------------------------------- Discovery ----------------------------------

discovery.zen.ping.unicast.hosts: ["20.138.120.85"]
discovery.zen.minimum_master_nodes: 1

----------------------------------Gateway -----------------------------------

---------------------------------- Various -----------------------------------

xpack.monitoring.enabled: true
xpack.monitoring.collection.enabled: true
xpack.security.enabled: true

Node 2

======================== Elasticsearch Configuration =========================

---------------------------------- Cluster -----------------------------------

cluster.name: Torvlads

------------------------------------ Node ------------------------------------

node.name: node-2 - 85
node.master: false
node.data: true

----------------------------------- Paths ------------------------------------

path.data: /opt/elastic
path.logs: /var/log/elasticsearch

----------------------------------- Memory -----------------------------------

---------------------------------- Network -----------------------------------

network.host: 0.0.0.0
http.port: 9200

--------------------------------- Discovery ----------------------------------

discovery.zen.ping.unicast.hosts: ["20.138.120.84",]
discovery.zen.minimum_master_nodes: 2

---------------------------------- Gateway -----------------------------------

---------------------------------- Various -----------------------------------

#xpack.monitoring.enabled: true
#xpack.monitoring.collection.enabled: true
#xpack.security.enabled: true


#2

Your cluster names don't match. "Torvalds" vs. "Torvlads"


(Lowdmt) #3

Don't I feel like the idiot.

Typo.

Changed it and it worked.

I must of looked over that yml file 30 times.

Thank you


#4

Our brain is very good at over-looking typos especially in the middle of the word :wink:


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.