Help me get my cluster actually clustering, please


(David Reagan) #1

I have a single elasticsearch vm running and receiving data from logstash.
To see about improving performance, and to learn how to use clustering, I
created a second elasticsearch vm, and told it to use the same cluster.name
as the first one.

I think that's all I'm supposed to do in order to get clustering working,
right?

So, why do my elasticsearch nodes not see each other?

My first one sees itself and the logstash indexer. The second one only sees
itself. (I don't have logstash configured to send data to it...)

Both VM's are in the same DMZ, and neither have their own firewalls turned
on. According to my firewall person, the firewall doesn't block ports
between two servers in the same DMZ.

Running nmap on the first vm from the second vm says that ports 9200 and
9300 are open, but any others I test in between 9200-9400 are closed.

Is there another step I need to take in order to get clustering working?
Maybe something to tell elasticsearch to listen on all the ports it's
supposed to listen to?

I'm running version 0.90.3.

Thanks!

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(David Pilato) #2

If you are using multicast (default), then look at this: http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/modules-discovery-zen.html
You can use unicast (disable multicast) and give a list of nodes in elasticsearch.yml file.

HTH

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

8 novembre 2013 at 18:45:45, David Reagan (jerrac@gmail.com) a écrit:

I have a single elasticsearch vm running and receiving data from logstash. To see about improving performance, and to learn how to use clustering, I created a second elasticsearch vm, and told it to use the same cluster.name as the first one.

I think that's all I'm supposed to do in order to get clustering working, right?

So, why do my elasticsearch nodes not see each other?

My first one sees itself and the logstash indexer. The second one only sees itself. (I don't have logstash configured to send data to it...)

Both VM's are in the same DMZ, and neither have their own firewalls turned on. According to my firewall person, the firewall doesn't block ports between two servers in the same DMZ.

Running nmap on the first vm from the second vm says that ports 9200 and 9300 are open, but any others I test in between 9200-9400 are closed.

Is there another step I need to take in order to get clustering working? Maybe something to tell elasticsearch to listen on all the ports it's supposed to listen to?

I'm running version 0.90.3.

Thanks!

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Hendrik) #3

Are the two elastic servers in the same subnet? you can telnet them each
other on port 9200 and 9300?

Sometimes it helped me to adjust the following config properties in
elasticsearch.yml :

discovery.zen.ping.timeout: 3s -> 10s #maybe you have a slow network?

In your none master node set
discovery.zen.ping.unicast.hosts: ["hostname.masternode"] #or ip adress if
no dns

Make sure not only TCP, also UDP is not blocked by firewalls. You may check
this with nmap.

KR
Hendrik

Am Freitag, 8. November 2013 18:44:39 UTC+1 schrieb David Reagan:

I have a single elasticsearch vm running and receiving data from logstash.
To see about improving performance, and to learn how to use clustering, I
created a second elasticsearch vm, and told it to use the same
cluster.name as the first one.

I think that's all I'm supposed to do in order to get clustering working,
right?

So, why do my elasticsearch nodes not see each other?

My first one sees itself and the logstash indexer. The second one only
sees itself. (I don't have logstash configured to send data to it...)

Both VM's are in the same DMZ, and neither have their own firewalls turned
on. According to my firewall person, the firewall doesn't block ports
between two servers in the same DMZ.

Running nmap on the first vm from the second vm says that ports 9200 and
9300 are open, but any others I test in between 9200-9400 are closed.

Is there another step I need to take in order to get clustering working?
Maybe something to tell elasticsearch to listen on all the ports it's
supposed to listen to?

I'm running version 0.90.3.

Thanks!

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(David Reagan) #4

They are in the same subnet. Yes, I can telnet those ports.

I haven't tried unicast yet, but I have tried adding:

discovery.zen.ping.timeout: 10s

discovery.zen.ping.multicast.port: 8888
discovery.zen.ping.multicast.address: {{ nodes ip address }}

But it didn't seem to do anything.

I just ran curl -XGET 'http://localhost:9200/_nodes/transport?pretty' and
it says:

{

"ok" : true,
"cluster_name" : "logstash-webservices",
"nodes" : {
"kv3XbyDqQ-mFDEezVytQCA" : {
"name" : "Grappler",
"transport_address" : "inet[/10.225.0.82:9300]",
"hostname" : "log-indexer-01",
"version" : "0.90.3",
"attributes" : {
"client" : "true",
"data" : "false"
},
"transport" : {
"bound_address" : "inet[/0:0:0:0:0:0:0:0%0:9300]",
"publish_address" : "inet[/10.225.0.82:9300]"
}
},
"KQnCFpwJSJq5J-HJ9m3pLA" : {
"name" : "Amergin",
"transport_address" : "inet[/10.225.0.84:9300]",
"hostname" : "log-elasticsearch-01",
"version" : "0.90.3",
"http_address" : "inet[/10.225.0.84:9200]",
"transport" : {
"bound_address" : "inet[/0:0:0:0:0:0:0:0:9300]",
"publish_address" : "inet[/10.225.0.84:9300]"
}
}
}
}

Does the "bound_address" : "inet[/0:0:0:0:0:0:0:0:9300]" mean it's only
listening on ipv6?

--David Reagan

On Fri, Nov 8, 2013 at 10:26 AM, Hendrik h.j.saly@googlemail.com wrote:

Are the two elastic servers in the same subnet? you can telnet them each
other on port 9200 and 9300?

Sometimes it helped me to adjust the following config properties in
elasticsearch.yml :

discovery.zen.ping.timeout: 3s -> 10s #maybe you have a slow network?

In your none master node set
discovery.zen.ping.unicast.hosts: ["hostname.masternode"] #or ip adress if
no dns

Make sure not only TCP, also UDP is not blocked by firewalls. You may
check this with nmap.

KR
Hendrik

Am Freitag, 8. November 2013 18:44:39 UTC+1 schrieb David Reagan:

I have a single elasticsearch vm running and receiving data from
logstash. To see about improving performance, and to learn how to use
clustering, I created a second elasticsearch vm, and told it to use the
same cluster.name as the first one.

I think that's all I'm supposed to do in order to get clustering working,
right?

So, why do my elasticsearch nodes not see each other?

My first one sees itself and the logstash indexer. The second one only
sees itself. (I don't have logstash configured to send data to it...)

Both VM's are in the same DMZ, and neither have their own firewalls
turned on. According to my firewall person, the firewall doesn't block
ports between two servers in the same DMZ.

Running nmap on the first vm from the second vm says that ports 9200 and
9300 are open, but any others I test in between 9200-9400 are closed.

Is there another step I need to take in order to get clustering working?
Maybe something to tell elasticsearch to listen on all the ports it's
supposed to listen to?

I'm running version 0.90.3.

Thanks!

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/jUYA7WVWpKw/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Mark Walkom) #5

Try using a monitoring plugin to give you a more complete view on things,
the API is nice but it can be tedious to have to cur every time you want to
check something.

By the looks of that you have two nodes in the cluster -
log-indexer-01 and log-elasticsearch-01

  • running on 10.255.0.82 and 10.255.0.84 respectively.

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: markw@campaignmonitor.com
web: www.campaignmonitor.com

On 9 November 2013 06:13, David Reagan jerrac@gmail.com wrote:

They are in the same subnet. Yes, I can telnet those ports.

I haven't tried unicast yet, but I have tried adding:

discovery.zen.ping.timeout: 10s

discovery.zen.ping.multicast.port: 8888
discovery.zen.ping.multicast.address: {{ nodes ip address }}

But it didn't seem to do anything.

I just ran curl -XGET 'http://localhost:9200/_nodes/transport?pretty' and
it says:

{

"ok" : true,
"cluster_name" : "logstash-webservices",
"nodes" : {
"kv3XbyDqQ-mFDEezVytQCA" : {
"name" : "Grappler",
"transport_address" : "inet[/10.225.0.82:9300]",
"hostname" : "log-indexer-01",
"version" : "0.90.3",
"attributes" : {
"client" : "true",
"data" : "false"
},
"transport" : {
"bound_address" : "inet[/0:0:0:0:0:0:0:0%0:9300]",
"publish_address" : "inet[/10.225.0.82:9300]"
}
},
"KQnCFpwJSJq5J-HJ9m3pLA" : {
"name" : "Amergin",
"transport_address" : "inet[/10.225.0.84:9300]",
"hostname" : "log-elasticsearch-01",
"version" : "0.90.3",
"http_address" : "inet[/10.225.0.84:9200]",
"transport" : {
"bound_address" : "inet[/0:0:0:0:0:0:0:0:9300]",
"publish_address" : "inet[/10.225.0.84:9300]"
}
}
}
}

Does the "bound_address" : "inet[/0:0:0:0:0:0:0:0:9300]" mean it's only
listening on ipv6?

--David Reagan

On Fri, Nov 8, 2013 at 10:26 AM, Hendrik h.j.saly@googlemail.com wrote:

Are the two elastic servers in the same subnet? you can telnet them each
other on port 9200 and 9300?

Sometimes it helped me to adjust the following config properties in
elasticsearch.yml :

discovery.zen.ping.timeout: 3s -> 10s #maybe you have a slow network?

In your none master node set
discovery.zen.ping.unicast.hosts: ["hostname.masternode"] #or ip adress
if no dns

Make sure not only TCP, also UDP is not blocked by firewalls. You may
check this with nmap.

KR
Hendrik

Am Freitag, 8. November 2013 18:44:39 UTC+1 schrieb David Reagan:

I have a single elasticsearch vm running and receiving data from
logstash. To see about improving performance, and to learn how to use
clustering, I created a second elasticsearch vm, and told it to use the
same cluster.name as the first one.

I think that's all I'm supposed to do in order to get clustering
working, right?

So, why do my elasticsearch nodes not see each other?

My first one sees itself and the logstash indexer. The second one only
sees itself. (I don't have logstash configured to send data to it...)

Both VM's are in the same DMZ, and neither have their own firewalls
turned on. According to my firewall person, the firewall doesn't block
ports between two servers in the same DMZ.

Running nmap on the first vm from the second vm says that ports 9200 and
9300 are open, but any others I test in between 9200-9400 are closed.

Is there another step I need to take in order to get clustering working?
Maybe something to tell elasticsearch to listen on all the ports it's
supposed to listen to?

I'm running version 0.90.3.

Thanks!

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/jUYA7WVWpKw/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(David Pilato) #6

Your settings are incorrect. Look at examples here: https://github.com/elasticsearch/elasticsearch/blob/master/config/elasticsearch.yml#L293

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 8 nov. 2013 à 19:22, David Pilato david@pilato.fr a écrit :

If you are using multicast (default), then look at this: http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/modules-discovery-zen.html
You can use unicast (disable multicast) and give a list of nodes in elasticsearch.yml file.

HTH

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

8 novembre 2013 at 18:45:45, David Reagan (jerrac@gmail.com) a écrit:

I have a single elasticsearch vm running and receiving data from logstash. To see about improving performance, and to learn how to use clustering, I created a second elasticsearch vm, and told it to use the same cluster.name as the first one.

I think that's all I'm supposed to do in order to get clustering working, right?

So, why do my elasticsearch nodes not see each other?

My first one sees itself and the logstash indexer. The second one only sees itself. (I don't have logstash configured to send data to it...)

Both VM's are in the same DMZ, and neither have their own firewalls turned on. According to my firewall person, the firewall doesn't block ports between two servers in the same DMZ.

Running nmap on the first vm from the second vm says that ports 9200 and 9300 are open, but any others I test in between 9200-9400 are closed.

Is there another step I need to take in order to get clustering working? Maybe something to tell elasticsearch to listen on all the ports it's supposed to listen to?

I'm running version 0.90.3.

Thanks!

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.
--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(David Reagan) #7

@Mark the logstash node is not an elasticsearch node. It's what Logstash
registers as when using the Elasticsearch output plugin.

If clustering was working for me, there would 3 nodes, logstash's output
plugin, elasticsearch-01, and elasticsearch-02.

@David I uncommented what settings were in that config file, and added the
ones mentioned here:
http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/modules-discovery-zen.html#multicastIf
they're wrong, then the docs are misleading me.

--David Reagan

On Fri, Nov 8, 2013 at 11:54 AM, David Pilato david@pilato.fr wrote:

Your settings are incorrect. Look at examples here:
https://github.com/elasticsearch/elasticsearch/blob/master/config/elasticsearch.yml#L293

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 8 nov. 2013 à 19:22, David Pilato david@pilato.fr a écrit :

If you are using multicast (default), then look at this:
http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/modules-discovery-zen.html
You can use unicast (disable multicast) and give a list of nodes in
elasticsearch.yml file.

HTH

--
David Pilato | Technical Advocate | Elasticsearch.com
http://Elasticsearch.com

@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

8 novembre 2013 at 18:45:45, David Reagan (jerrac@gmail.com//jerrac@gmail.com)
a écrit:

I have a single elasticsearch vm running and receiving data from logstash.
To see about improving performance, and to learn how to use clustering, I
created a second elasticsearch vm, and told it to use the same
cluster.name as the first one.

I think that's all I'm supposed to do in order to get clustering working,
right?

So, why do my elasticsearch nodes not see each other?

My first one sees itself and the logstash indexer. The second one only
sees itself. (I don't have logstash configured to send data to it...)

Both VM's are in the same DMZ, and neither have their own firewalls turned
on. According to my firewall person, the firewall doesn't block ports
between two servers in the same DMZ.

Running nmap on the first vm from the second vm says that ports 9200 and
9300 are open, but any others I test in between 9200-9400 are closed.

Is there another step I need to take in order to get clustering working?
Maybe something to tell elasticsearch to listen on all the ports it's
supposed to listen to?

I'm running version 0.90.3.

Thanks!

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/jUYA7WVWpKw/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(David Pilato) #8

It should be:

discovery.zen.ping.multicast.enabled: false
discovery.zen.ping.unicast.hosts: ["host1", "host2:port"]

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 8 nov. 2013 à 21:08, David Reagan jerrac@gmail.com a écrit :

@Mark the logstash node is not an elasticsearch node. It's what Logstash registers as when using the Elasticsearch output plugin.

If clustering was working for me, there would 3 nodes, logstash's output plugin, elasticsearch-01, and elasticsearch-02.

@David I uncommented what settings were in that config file, and added the ones mentioned here: http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/modules-discovery-zen.html#multicast If they're wrong, then the docs are misleading me.

--David Reagan

On Fri, Nov 8, 2013 at 11:54 AM, David Pilato david@pilato.fr wrote:
Your settings are incorrect. Look at examples here: https://github.com/elasticsearch/elasticsearch/blob/master/config/elasticsearch.yml#L293

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 8 nov. 2013 à 19:22, David Pilato david@pilato.fr a écrit :

If you are using multicast (default), then look at this: http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/modules-discovery-zen.html
You can use unicast (disable multicast) and give a list of nodes in elasticsearch.yml file.

HTH

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

8 novembre 2013 at 18:45:45, David Reagan (jerrac@gmail.com) a écrit:

I have a single elasticsearch vm running and receiving data from logstash. To see about improving performance, and to learn how to use clustering, I created a second elasticsearch vm, and told it to use the same cluster.name as the first one.

I think that's all I'm supposed to do in order to get clustering working, right?

So, why do my elasticsearch nodes not see each other?

My first one sees itself and the logstash indexer. The second one only sees itself. (I don't have logstash configured to send data to it...)

Both VM's are in the same DMZ, and neither have their own firewalls turned on. According to my firewall person, the firewall doesn't block ports between two servers in the same DMZ.

Running nmap on the first vm from the second vm says that ports 9200 and 9300 are open, but any others I test in between 9200-9400 are closed.

Is there another step I need to take in order to get clustering working? Maybe something to tell elasticsearch to listen on all the ports it's supposed to listen to?

I'm running version 0.90.3.

Thanks!

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.
--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.
--
You received this message because you are subscribed to a topic in the Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/elasticsearch/jUYA7WVWpKw/unsubscribe.
To unsubscribe from this group and all its topics, send an email to elasticsearch+unsubscribe@googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(David Reagan) #9

I haven't tried unicast yet, so turning off multicast wouldn't help.

--David Reagan

On Fri, Nov 8, 2013 at 12:14 PM, David Pilato david@pilato.fr wrote:

It should be:

discovery.zen.ping.multicast.enabled: false

discovery.zen.ping.unicast.hosts: ["host1", "host2:port"]

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 8 nov. 2013 à 21:08, David Reagan jerrac@gmail.com a écrit :

@Mark the logstash node is not an elasticsearch node. It's what Logstash
registers as when using the Elasticsearch output plugin.

If clustering was working for me, there would 3 nodes, logstash's output
plugin, elasticsearch-01, and elasticsearch-02.

@David I uncommented what settings were in that config file, and added the
ones mentioned here:
http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/modules-discovery-zen.html#multicastIf they're wrong, then the docs are misleading me.

--David Reagan

On Fri, Nov 8, 2013 at 11:54 AM, David Pilato david@pilato.fr wrote:

Your settings are incorrect. Look at examples here:
https://github.com/elasticsearch/elasticsearch/blob/master/config/elasticsearch.yml#L293

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 8 nov. 2013 à 19:22, David Pilato david@pilato.fr a écrit :

If you are using multicast (default), then look at this:
http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/modules-discovery-zen.html
You can use unicast (disable multicast) and give a list of nodes in
elasticsearch.yml file.

HTH

--
David Pilato | Technical Advocate | Elasticsearch.com
http://Elasticsearch.com

@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

8 novembre 2013 at 18:45:45, David Reagan (jerrac@gmail.com//jerrac@gmail.com)
a écrit:

I have a single elasticsearch vm running and receiving data from
logstash. To see about improving performance, and to learn how to use
clustering, I created a second elasticsearch vm, and told it to use the
same cluster.name as the first one.

I think that's all I'm supposed to do in order to get clustering working,
right?

So, why do my elasticsearch nodes not see each other?

My first one sees itself and the logstash indexer. The second one only
sees itself. (I don't have logstash configured to send data to it...)

Both VM's are in the same DMZ, and neither have their own firewalls
turned on. According to my firewall person, the firewall doesn't block
ports between two servers in the same DMZ.

Running nmap on the first vm from the second vm says that ports 9200 and
9300 are open, but any others I test in between 9200-9400 are closed.

Is there another step I need to take in order to get clustering working?
Maybe something to tell elasticsearch to listen on all the ports it's
supposed to listen to?

I'm running version 0.90.3.

Thanks!

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/jUYA7WVWpKw/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/jUYA7WVWpKw/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(David Pilato) #10

I hope we have provided all the answers you need to make it work. Let me sum up that:

1st: multicast
Make sure it can work between your VMs on a Network level (UDP and port described in doc).

2nd: unicast. If you can't do multicast (which is the case in cloud environment for example), switch to unicast using the two lines I wrote.

Also, note that you don't need to run VMs if you just want to test Elasticsearch clustering. Just start from the same dir:
bin/elasticsearch -f
bin/elasticsearch -f
bin/elasticsearch -f
bin/elasticsearch -f

And you're done.

I can't see any other information I can add here. May be others have new ideas?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 8 nov. 2013 à 21:16, David Reagan jerrac@gmail.com a écrit :

I haven't tried unicast yet, so turning off multicast wouldn't help.

--David Reagan

On Fri, Nov 8, 2013 at 12:14 PM, David Pilato david@pilato.fr wrote:
It should be:

discovery.zen.ping.multicast.enabled: false
discovery.zen.ping.unicast.hosts: ["host1", "host2:port"]

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 8 nov. 2013 à 21:08, David Reagan jerrac@gmail.com a écrit :

@Mark the logstash node is not an elasticsearch node. It's what Logstash registers as when using the Elasticsearch output plugin.

If clustering was working for me, there would 3 nodes, logstash's output plugin, elasticsearch-01, and elasticsearch-02.

@David I uncommented what settings were in that config file, and added the ones mentioned here: http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/modules-discovery-zen.html#multicast If they're wrong, then the docs are misleading me.

--David Reagan

On Fri, Nov 8, 2013 at 11:54 AM, David Pilato david@pilato.fr wrote:
Your settings are incorrect. Look at examples here: https://github.com/elasticsearch/elasticsearch/blob/master/config/elasticsearch.yml#L293

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 8 nov. 2013 à 19:22, David Pilato david@pilato.fr a écrit :

If you are using multicast (default), then look at this: http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/modules-discovery-zen.html
You can use unicast (disable multicast) and give a list of nodes in elasticsearch.yml file.

HTH

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

8 novembre 2013 at 18:45:45, David Reagan (jerrac@gmail.com) a écrit:

I have a single elasticsearch vm running and receiving data from logstash. To see about improving performance, and to learn how to use clustering, I created a second elasticsearch vm, and told it to use the same cluster.name as the first one.

I think that's all I'm supposed to do in order to get clustering working, right?

So, why do my elasticsearch nodes not see each other?

My first one sees itself and the logstash indexer. The second one only sees itself. (I don't have logstash configured to send data to it...)

Both VM's are in the same DMZ, and neither have their own firewalls turned on. According to my firewall person, the firewall doesn't block ports between two servers in the same DMZ.

Running nmap on the first vm from the second vm says that ports 9200 and 9300 are open, but any others I test in between 9200-9400 are closed.

Is there another step I need to take in order to get clustering working? Maybe something to tell elasticsearch to listen on all the ports it's supposed to listen to?

I'm running version 0.90.3.

Thanks!

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.
--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.
--
You received this message because you are subscribed to a topic in the Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/elasticsearch/jUYA7WVWpKw/unsubscribe.
To unsubscribe from this group and all its topics, send an email to elasticsearch+unsubscribe@googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

You received this message because you are subscribed to a topic in the Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/elasticsearch/jUYA7WVWpKw/unsubscribe.
To unsubscribe from this group and all its topics, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(David Reagan) #11

These VM's are on a VMWare cloud. So I'm wondering if that's why multicast
won't work. I've been searching around trying to confirm that before I test
unicast.

--David Reagan

On Fri, Nov 8, 2013 at 1:00 PM, David Pilato david@pilato.fr wrote:

I hope we have provided all the answers you need to make it work. Let me
sum up that:

1st: multicast
Make sure it can work between your VMs on a Network level (UDP and port
described in doc).

2nd: unicast. If you can't do multicast (which is the case in cloud
environment for example), switch to unicast using the two lines I wrote.

Also, note that you don't need to run VMs if you just want to test
Elasticsearch clustering. Just start from the same dir:
bin/elasticsearch -f
bin/elasticsearch -f
bin/elasticsearch -f
bin/elasticsearch -f

And you're done.

I can't see any other information I can add here. May be others have new
ideas?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 8 nov. 2013 à 21:16, David Reagan jerrac@gmail.com a écrit :

I haven't tried unicast yet, so turning off multicast wouldn't help.

--David Reagan

On Fri, Nov 8, 2013 at 12:14 PM, David Pilato david@pilato.fr wrote:

It should be:

discovery.zen.ping.multicast.enabled: false

discovery.zen.ping.unicast.hosts: ["host1", "host2:port"]

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 8 nov. 2013 à 21:08, David Reagan jerrac@gmail.com a écrit :

@Mark the logstash node is not an elasticsearch node. It's what Logstash
registers as when using the Elasticsearch output plugin.

If clustering was working for me, there would 3 nodes, logstash's output
plugin, elasticsearch-01, and elasticsearch-02.

@David I uncommented what settings were in that config file, and added
the ones mentioned here:
http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/modules-discovery-zen.html#multicastIf they're wrong, then the docs are misleading me.

--David Reagan

On Fri, Nov 8, 2013 at 11:54 AM, David Pilato david@pilato.fr wrote:

Your settings are incorrect. Look at examples here:
https://github.com/elasticsearch/elasticsearch/blob/master/config/elasticsearch.yml#L293

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 8 nov. 2013 à 19:22, David Pilato david@pilato.fr a écrit :

If you are using multicast (default), then look at this:
http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/modules-discovery-zen.html
You can use unicast (disable multicast) and give a list of nodes in
elasticsearch.yml file.

HTH

--
David Pilato | Technical Advocate | Elasticsearch.com
http://Elasticsearch.com

@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

8 novembre 2013 at 18:45:45, David Reagan (jerrac@gmail.com//jerrac@gmail.com)
a écrit:

I have a single elasticsearch vm running and receiving data from
logstash. To see about improving performance, and to learn how to use
clustering, I created a second elasticsearch vm, and told it to use the
same cluster.name as the first one.

I think that's all I'm supposed to do in order to get clustering
working, right?

So, why do my elasticsearch nodes not see each other?

My first one sees itself and the logstash indexer. The second one only
sees itself. (I don't have logstash configured to send data to it...)

Both VM's are in the same DMZ, and neither have their own firewalls
turned on. According to my firewall person, the firewall doesn't block
ports between two servers in the same DMZ.

Running nmap on the first vm from the second vm says that ports 9200 and
9300 are open, but any others I test in between 9200-9400 are closed.

Is there another step I need to take in order to get clustering working?
Maybe something to tell elasticsearch to listen on all the ports it's
supposed to listen to?

I'm running version 0.90.3.

Thanks!

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/jUYA7WVWpKw/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/jUYA7WVWpKw/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/jUYA7WVWpKw/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(David Reagan) #12

Yep, unicast works. sigh

Thanks for the help. :slight_smile:

--David Reagan

On Fri, Nov 8, 2013 at 1:13 PM, David Reagan jerrac@gmail.com wrote:

These VM's are on a VMWare cloud. So I'm wondering if that's why multicast
won't work. I've been searching around trying to confirm that before I test
unicast.

--David Reagan

On Fri, Nov 8, 2013 at 1:00 PM, David Pilato david@pilato.fr wrote:

I hope we have provided all the answers you need to make it work. Let me
sum up that:

1st: multicast
Make sure it can work between your VMs on a Network level (UDP and port
described in doc).

2nd: unicast. If you can't do multicast (which is the case in cloud
environment for example), switch to unicast using the two lines I wrote.

Also, note that you don't need to run VMs if you just want to test
Elasticsearch clustering. Just start from the same dir:
bin/elasticsearch -f
bin/elasticsearch -f
bin/elasticsearch -f
bin/elasticsearch -f

And you're done.

I can't see any other information I can add here. May be others have new
ideas?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 8 nov. 2013 à 21:16, David Reagan jerrac@gmail.com a écrit :

I haven't tried unicast yet, so turning off multicast wouldn't help.

--David Reagan

On Fri, Nov 8, 2013 at 12:14 PM, David Pilato david@pilato.fr wrote:

It should be:

discovery.zen.ping.multicast.enabled: false

discovery.zen.ping.unicast.hosts: ["host1", "host2:port"]

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 8 nov. 2013 à 21:08, David Reagan jerrac@gmail.com a écrit :

@Mark the logstash node is not an elasticsearch node. It's what Logstash
registers as when using the Elasticsearch output plugin.

If clustering was working for me, there would 3 nodes, logstash's output
plugin, elasticsearch-01, and elasticsearch-02.

@David I uncommented what settings were in that config file, and added
the ones mentioned here:
http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/modules-discovery-zen.html#multicastIf they're wrong, then the docs are misleading me.

--David Reagan

On Fri, Nov 8, 2013 at 11:54 AM, David Pilato david@pilato.fr wrote:

Your settings are incorrect. Look at examples here:
https://github.com/elasticsearch/elasticsearch/blob/master/config/elasticsearch.yml#L293

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 8 nov. 2013 à 19:22, David Pilato david@pilato.fr a écrit :

If you are using multicast (default), then look at this:
http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/modules-discovery-zen.html
You can use unicast (disable multicast) and give a list of nodes in
elasticsearch.yml file.

HTH

--
David Pilato | Technical Advocate | Elasticsearch.com
http://Elasticsearch.com

@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

8 novembre 2013 at 18:45:45, David Reagan (jerrac@gmail.com//jerrac@gmail.com)
a écrit:

I have a single elasticsearch vm running and receiving data from
logstash. To see about improving performance, and to learn how to use
clustering, I created a second elasticsearch vm, and told it to use the
same cluster.name as the first one.

I think that's all I'm supposed to do in order to get clustering
working, right?

So, why do my elasticsearch nodes not see each other?

My first one sees itself and the logstash indexer. The second one only
sees itself. (I don't have logstash configured to send data to it...)

Both VM's are in the same DMZ, and neither have their own firewalls
turned on. According to my firewall person, the firewall doesn't block
ports between two servers in the same DMZ.

Running nmap on the first vm from the second vm says that ports 9200
and 9300 are open, but any others I test in between 9200-9400 are closed.

Is there another step I need to take in order to get clustering
working? Maybe something to tell elasticsearch to listen on all the ports
it's supposed to listen to?

I'm running version 0.90.3.

Thanks!

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/jUYA7WVWpKw/unsubscribe
.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/jUYA7WVWpKw/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/jUYA7WVWpKw/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #13