Help me increase index.max_result_window level


#1

I am trying to use ElasticSearch on Invision forum software, it works generally but there is an error and its causing tasks to crash. This is the error

Result window is too large, from + size must be less than or equal to: [10000] but was [11450]. See the scroll api for a more efficient way to request large data sets. This limit can be set by changing the [index.max_result_window] index level setting.

How do I instruct my host to increase this setting?


(Mark Harwood) #2

You might not want to. That setting is a safeguard to avoid your servers running out of memory.
"Deep pagination" causes this which is why search engines like Google similarly don't let you page endlessly through millions of results.
If you really, really do need deep pagination then there are specialised elasticsearch APIs (scroll and search after ) that Invision should be using which are more efficient and avoid running out of memory.


(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.