HELP! Specifying an analyzer path of a nested object of a mapping

Hello,

I need an to specify a dynamic analyzer that matches a specific element in
my object but the path is not as simple as the example in
http://www.elasticsearch.org/guide/reference/mapping/analyzer-field.html.

I have the following mapping:

{
"type1" : {
"_analyzer" : {
"path" : "locale"
},
"properties" : {
"context" : {"type" : "string", "index" : "no"},
"graph" : {
"properties" : {
"locale" : "en",
"other_field" : "blabla"
}
}
}

}

}

I've ran some tests and it seems that it is not finding the "locale" field. How can I specify that the path is "locale" inside "graph"?

Thank you for your help.

Regards,
Carla

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

On Tue, 2013-01-29 at 11:16 -0800, carla.cuesta@gmail.com wrote:

Hello,

I need an to specify a dynamic analyzer that matches a specific
element in my object but the path is not as simple as the example in
http://www.elasticsearch.org/guide/reference/mapping/analyzer-field.html.

I have the following mapping:

{
"type1" : {
"_analyzer" : {
"path" : "locale"
},
"properties" : {
"context" : {"type" : "string", "index" : "no"},
"graph" : {
"properties" : {
"locale" : "en",
"other_field" : "blabla"
}
}
}
}
}

I've ran some tests and it seems that it is not finding the "locale" field. How can I specify that the path is "locale" inside "graph"?

Try setting the path to 'graph.locale'

clint

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

That worked!! Thank you very much for your help!! :slight_smile:

On 30/01/2013, at 10:46, Clinton Gormley clint@traveljury.com wrote:

On Tue, 2013-01-29 at 11:16 -0800, carla.cuesta@gmail.com wrote:

Hello,

I need an to specify a dynamic analyzer that matches a specific
element in my object but the path is not as simple as the example in
http://www.elasticsearch.org/guide/reference/mapping/analyzer-field.html.

I have the following mapping:

{
"type1" : {
"_analyzer" : {
"path" : "locale"
},
"properties" : {
"context" : {"type" : "string", "index" : "no"},
"graph" : {
"properties" : {
"locale" : "en",
"other_field" : "blabla"
}
}
}
}
}

I've ran some tests and it seems that it is not finding the "locale" field. How can I specify that the path is "locale" inside "graph"?
Try setting the path to 'graph.locale'

clint

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.